Page MenuHomePhabricator

Discussion is broken on Mac mobile Web site
Closed, ResolvedPublic3 Story Points

Description

Test plan

  • On IOS 10.0.2 and Chrome browser, go to the mobile web site and login.
  • Go to https://en.m.wikipedia.beta.wmflabs.org/wiki/Barack_Obama and scroll to the bottom. Click on the Discussion button.
  • On the Talk page, click to contribute to a discussion.
  • A Reply text box appears. Click into the text box, and a keyboard appears BUT
  • The text box disappears.

Also, please test on iOS 5, 6, 7, 8, and 9.

You can type, and your typing will be visible once you click back on the page to close the keyboard. But this isn't helpful because you can't see the text box you're typing into, nor can you scroll down to view it. It is hidden as long as the keyboard is visible.

BTW, I tried to do this in Safari browser, and couldn't because no Talk page button was displayed at all. Is that a separate bug?

Event Timeline

Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptOct 27 2016, 8:16 PM
โ€ข jmatazzoni added a comment.EditedOct 27 2016, 8:24 PM

I just noticed that when I encountered the issue above, I was in some kind of unnamed mode. I can tell this because I now see a link waaaaay at the bottom of the page that says "Read as wiki page." See screenshot attached. (Since it appears I wasn't looking at a "wiki page," I'd be curious to know what I was looking at? I don't have mobile Beta enabled...)

โ€ข jmatazzoni triaged this task as Unbreak Now! priority.Oct 27 2016, 8:27 PM
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. ยท View Herald TranscriptOct 27 2016, 8:27 PM
ovasileva moved this task from Upcoming to Incoming on the Readers-Web-Backlog board.
Zppix added a subscriber: Zppix.Nov 1 2016, 2:42 PM

confirmed on later version of IOS 8.1

phuedx added a subscriber: phuedx.Nov 1 2016, 3:38 PM

Thanks for the bug report @jmatazzoni!

BTW, I tried to do this in Safari browser, and couldn't because no Talk page button was displayed at all. Is that a separate bug?

I've been able to start a conversation and respond to it on Safari for iOS 10.1. I can confirm that I see the Talk button on mainspace pages in the same browser.

ovasileva lowered the priority of this task from Unbreak Now! to Normal.Nov 1 2016, 4:38 PM

This smells a lot like T129360. It reuses a lot of the same code as the editor.

This happens in Chrome (54.0.2840.71), Safari (10.0.1), and Firefox (49.0.2) on macOS Sierra (10.12.1). T149363#2760085 is still relevant.

@ovasileva: I'd recommend raising the priority to UBN!

@phuedx - done, also lining up for sprint + 1

ovasileva raised the priority of this task from Normal to Unbreak Now!.Nov 2 2016, 6:39 PM

Id recommend high at most. This doesnt seem to meet the definition of unbreak now which is drop everything to fix. (The fact you out this in next sprint and not this one proves that it's not :))

phuedx added a comment.Nov 3 2016, 9:33 AM
This comment was removed by phuedx.
ovasileva lowered the priority of this task from Unbreak Now! to High.Nov 7 2016, 5:21 PM
ovasileva set the point value for this task to 3.Nov 7 2016, 5:27 PM

@Nicholas.tsg - Hi Nicholas - we were hoping you could help us with reproducing this bug through various devices/browsers (in addition to the ones stated above)

This is still an issue in Chrome as seen in two videos I've attached,

iOS 10.0.2 (iPhone)

and

Android 4.4.2 (Galaxy SIII)

This as far as I've noticed was a Chrome-specific situation and I haven't noticed it in other browser apps such as iOS's Safari or Android's Internet Browser.

moving back to needs analysis

So the problem is the keyboard covers the textbox and doesn't shift the viewport when it's visible.

Note this could be related to T148794 due to the positioning/dimension issues we are seeing there.

Change 322117 had a related patch set uploaded (by Jdlrobson):
Limit ios header hack to older versions

https://gerrit.wikimedia.org/r/322117

Waiting for reply from @bmansurov before going ahead and fixing up Limit ios header hack to older versions but precursor patch Scope talk styles to talk overlay is ready to go!

bmansurov updated the task description. (Show Details)
bmansurov updated the task description. (Show Details)

Change 322117 merged by jenkins-bot:
Fix for ios talk overlay when virtual keyboard open

https://gerrit.wikimedia.org/r/322117

bmansurov updated the task description. (Show Details)Nov 21 2016, 10:08 PM
bmansurov updated the task description. (Show Details)

This appears to be fixed in Chrome as seen in the following screencaps for
iOS 7


and
iOS 10.2

ovasileva closed this task as Resolved.Nov 28 2016, 11:55 AM