Page MenuHomePhabricator

Babel Extension - Issue with ASE language code
Closed, ResolvedPublic

Description

The language code "ase" (American Sign Language) does not work correctly in Wikimedia user language boxes. See my Wikimedia userpage for an example.

Steps to Reproduce:

  1. Add {{#babel:ase-3}} to a Wikimedia userpage.

Actual results:
Next to "ase-3", the Babel userbox reads "This user has advanced knowledge of English".

Expected results:
Next to "ase-3", the Babel userbox reads "This user has advanced knowledge of American Sign Language".

Note: The code "ase" works correctly for Wikipedia user pages but not Wikimedia user pages. This issue seems to impact numerous languages on Wikimedia, not just ASE.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 11 2016, 8:40 PM

We have substantially the same problem with "jam" (Jamaican patois). If I hard-code "jam-0" the userbox reads (in jam, to be sure) "This user has no knowledge of English." (Expected: "This user has no knowledge of Patois.")

Additionally, at least on some Wikimedia user pages the #switch function doesn't recognize jam has a valid value for a language. Thus, any babel call depending on a switch (see my user page on Meta, if you like) doesn't recognize jam at all. Perhaps this is two separate problems; I don't know.

I've replied (hopefully with correct details) at https://meta.wikimedia.org/wiki/Talk:User_language#Issue_with_ase - If that's the only thing that needs to be done to fix this (and I think it is), please close this task. :-)
(Note, it normally takes at least 24 hours for fixes at translatewiki to get pushed to production. However there's currently a technical problem with the cron job, so there will be no updates till that's fixed)

AnotherPoint added a comment.EditedDec 12 2016, 7:48 PM

As I noted earlier, multiple languages seem to have issues with Babel userboxes in Wikimedia. It would help if the settings in Wikipedia, where these issues seem to be solved, could somehow be copied over.

The information Quiddity provided will hopefully help document what other users need to do to get their favourite Babel userboxes fixed.

I recommend increased priority on fixing the cron job issue.

As I noted earlier, multiple languages seem to have issues with Babel userboxes in Wikimedia. It would help if the settings in Wikipedia, where these issues seem to be solved, could somehow be copied over.

IIUC (not certain) the English Wikipedia has some old custom userboxes, which I think are overriding the babel defaults.
E.g. https://en.wikipedia.org/wiki/Template:User_ase-3 which (IIUC) overrides https://en.wikipedia.org/wiki/MediaWiki:Babel-3/ase
If true, this prevents anyone from seeing the problem at Enwiki, thus reducing the number of people who could potentially help. :-(
There is no easy solution, beyond updating the messages at translatewiki so that all wikis outside of Enwiki can benefit.
(A hypothetical solution would be for the userboxes at Enwiki to be deleted, thus restoring the defaults to be what is seen, but that would create problems for editors who want the plain userbox and not the full babel system)

We have substantially the same problem with "jam" (Jamaican patois). If I hard-code "jam-0" the userbox reads (in jam, to be sure) "This user has no knowledge of English." (Expected: "This user has no knowledge of Patois.")
Additionally, at least on some Wikimedia user pages the #switch function doesn't recognize jam has a valid value for a language. Thus, any babel call depending on a switch (see my user page on Meta, if you like) doesn't recognize jam at all. Perhaps this is two separate problems; I don't know.

Ah, it looks like there's yet another system available here, so you'll need to follow the instructions in https://meta.wikimedia.org/wiki/Template:User_language#Translating_the_template - again, not certain.

TTO closed this task as Resolved.Jan 1 2017, 9:56 AM
TTO claimed this task.
TTO added a subscriber: TTO.

Seems fixed now: https://test2.wikipedia.org/wiki/User:This,_that_and_the_other

I suspect this was a local issue at Meta. The built-in Babel system is working fine for ase and jam.

StevenJ81 added a comment.EditedJan 3 2017, 9:44 PM

It was partly a translatewiki issue and partly a local problem. At translatewiki, all of the Babel boxes had "Ingglish" instead of "Jumiekan" in them. (Alternatively, they had "English" instead of "American Sign Language".) That was an easy fix at translatewiki.

As to why jam wasn't working as a language choice at Meta, the reason is because Meta uses the construction {{int:lang}}, meaning it has to call a variable <lang>. That doesn't exist on translatewiki, only locally on Meta. And variable <lang> had no value when the language was set to jam. So I had to get a local sysop to create the page MediaWiki:Lang/jam with the contents "jam". Then everything worked fine.

Thanks for your help.