SpamBlacklist: cleanup.php maintenance script needs updating
Open, Needs TriagePublic

Description

Parent task to track work being done on cleanup.php (to be renamed to cleanupBlacklistedDomains.php).

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 2 2017, 12:13 PM

We should probably rename it to removeSpam.php to match with the current practice of naming maintenance scripts IMHO.

MarcoAurelio renamed this task from SpamBlacklist cleanup.php maintenance script updating to SpamBlacklist: cleanup.php maintenance script needs updating.Sep 19 2017, 2:27 PM
MarcoAurelio updated the task description. (Show Details)
MarcoAurelio added subscribers: tstarling, Legoktm, Krenair.

Added Tim as creator of the script, and Kunal & Alex as people that knows about these scripts.

For starters I'll rename it to cleanupBlacklistedDomains.php.

Zoranzoki21 added a subscriber: Zoranzoki21.

Change 379965 had a related patch set (by MarcoAurelio) published:
[mediawiki/extensions/SpamBlacklist@master] Rename cleanup.php and tweak documentation

https://gerrit.wikimedia.org/r/379965

Still to do:

  • rewrite so it works
  • dry-run option
  • option to delete
  • more?
He7d3r added a subscriber: He7d3r.Sep 25 2017, 12:36 AM

I noticed the script uses the username Spam cleanup script, and that this account was renamed on enwiki to Spam cleanup script~enwiki due to SUL finalization:
https://en.wikipedia.org/wiki/User:Spam_cleanup_script
Is that account supposed to be renamed? The old username only has contributions at incubator.wikimedia.org, according to
https://tools.wmflabs.org/guc/?user=Spam+cleanup+script

I'm thinking that, while we're updating the script, we could use the same account name cleanupSpam.php uses: "MediaWiki spam cleanup" which uses spambot_username MediaWiki i18n message. I don't think that'd be a problem since, for example, MediaWiki default is being used by other maintenance scripts so maybe we can do the same here as well.

I think I'll split this task into minor subtasks so it's workable.