Page MenuHomePhabricator

A generic preview is not shown for pages that do not exist
Closed, ResolvedPublic2 Estimated Story Points

Description

Visit https://en.wikipedia.beta.wmflabs.org/wiki/Dog?debug=true and hover over "the first domesticated animal" from the first paragraph. Nothing happens. A generic preview should show up.

Hovering over "working" from the same paragraph show a generic preview.

This only happens when a page is a redirect to another page that doesn't exist. I suppose it's rare in production, but on the beta cluster, we may have more cases like this.

it seems we handle RESTBase 404s differently from mediawiki API.
No change should be necessary in the REST endpoint.

QA

Upon hovering over "the first domesticated animal" https://en.wikipedia.beta.wmflabs.org/wiki/Dog?debug=true I should see a popup similar to:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 17 2017, 12:05 PM
ovasileva triaged this task as High priority.Mar 17 2017, 4:15 PM
ovasileva moved this task from Incoming to 2016-17 Q3 on the Readers-Web-Backlog board.
ovasileva moved this task from Needs Analysis to To Do on the Reading-Web-Sprint-94 board.

Change 343406 had a related patch set uploaded (by Bmansurov):
[mediawiki/extensions/Popups] WIP: Handle RESTBase 404

https://gerrit.wikimedia.org/r/343406

@Jhernandez can you take a look at the above patch and help me set up mw-node-qunit so that I can use a fake server in tests? Thanks.

bmansurov lowered the priority of this task from High to Medium.Mar 17 2017, 10:24 PM
bmansurov updated the task description. (Show Details)

@ovasileva lowered the priority because the problem is not as wide-spread as I thought initially. Feel free to raise it if you disagree after reading the updated description.

@bmansurov - good news. I agree with the lowered priority

ovasileva renamed this task from A generic preview is not shown for some links to A generic preview is not shown for pages that do not exist.Mar 20 2017, 5:08 PM
Jdlrobson updated the task description. (Show Details)Mar 20 2017, 5:19 PM
Jdlrobson set the point value for this task to 2.
Jdlrobson added a subscriber: Jdlrobson.

There's a jenkins issue and I've left you some questions.

Left some comments too.

Change 343406 merged by jenkins-bot:
[mediawiki/extensions/Popups@master] Handle RESTBase 404

https://gerrit.wikimedia.org/r/343406

Merged, tested on https://en.wikipedia.beta.wmflabs.org/wiki/Dog hovering over "the first domesticated animal".

ovasileva closed this task as Resolved.Apr 6 2017, 4:46 PM

tested as well, looks good!

bmansurov removed bmansurov as the assignee of this task.Apr 6 2017, 10:43 PM