Page MenuHomePhabricator

Links to Commons gallery (P935) and Commons category (P373) are not working
Closed, ResolvedPublic

Description

For some unknown reason, for me any of the values of Commons gallery (P935) and Commons category (P373) in Wikidata items are not linked and not clickable. I've disabled all custom user scripts (local and global) in order to find the cause, but nothing helped. Cleared cache, deleted cookies; no success. Tested logged out, and they works as expected. Then I tested with another accounts and it also works. Seems to be something related to (or caused by) my user account, as I've done tests in multiple browsers, and the result is the same in all of them. I'll attach to this post a capture of the page source of a random item "affected" by this issue - there is missing any link tag under the Commons page name value.

Event Timeline

XXN created this task.Mar 30 2017, 5:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 30 2017, 5:39 PM

Can you check your gadgets?

Also check your JavaScript console please. :)

XXN added a comment.EditedApr 7 2017, 3:19 PM

Few minutes ago I've repeated again the tests: disabled local & global user scripts, disabled all gadgets (before reporting this issue I've done also this thing, just forgot to mention it).
Accessed random item, first item with one of these properties (Commons category - P373) this time was - https://www.wikidata.org/wiki/Q1325096
Again verified in more than one browser, the same issue persists - logged out is ok, logged in (under this account) the link is missing.

The console message says:

This page is using the deprecated ResourceLoader module "jquery.ui.position".  load.php:28:950
This page is using the deprecated ResourceLoader module "jquery.ui.widget".  load.php:39:794
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead.  load.php:10:432
This page is using the deprecated ResourceLoader module "jquery.tipsy".  load.php:535:171
Your skin is incompatible with VisualEditor. See <https://www.mediawiki.org/wiki/VisualEditor/Skin_requirements> for the requirements.  load.php:441:173



After some time in console apperead one more message (I hope I didn't switched to another tab and it's caused by / related to the same tab of that item page)

XXN added a subscriber: Verdy_p.EditedApr 7 2017, 3:31 PM

See also https://www.wikidata.org/wiki/Property_talk:P373#Why_not_linked.3F
Other users, @matej_suchanek and @Verdy_p also said that sometimes they encounter this issue.

Lydia_Pintscher closed this task as Resolved.Apr 15 2017, 10:45 AM
Lydia_Pintscher claimed this task.
Lydia_Pintscher added a subscriber: Ladsgroup.

It seems @Ladsgroup fixed it :)

I found what's wrong with this. I'm finding a way the fix it atm

This would fix it. Clear the cache and have fun.

Strange. I tested and it worked for me. Anyway. Thanks for fixing it :)

XXN added a comment.EditedApr 17 2017, 8:02 PM

Unfortunately there is no change [for me].
I think I know how you can reproduce this problem, in 'an alternative way': apend ?safemode=1 to URL and you will see (probably) unlinked values for Commons gallery and Commons category.
This newly enabled feature is a kind of safe mode for wiki user accounts.(1)
Seems that these two properties are hardly influenced by other things.

If you use safemode=1, you disable *all* gadgets including the one that makes links (Authority control. Make sure you haven't disabled it by accident) and obviously it won't work :D The proper way to test it is by being logged out which shows links to me.

XXN added a comment.EditedApr 18 2017, 11:12 AM

Oh, God! I didn't knew that the links of these two properties are generated by this gadget. It was disabled for me for years, and with every test done to find the cause of the problem, I've disabled all gadgets...
Thank you @Ladsgroup.

It should be mentioned somewhere that disabling this gadget will leave unlinked values of P935 and P373.