Page MenuHomePhabricator

Creating the "interface editor" permission on Portuguese Wikivoyage
Closed, InvalidPublic

Description

There was a [http://pt.wikivoyage.org/wiki/Wikivoyage:Bar_dos_viajantes#Novo_estatuto consensus] on Wikivoyage in Portuguese approving the creation of an "interface editor" permission, containing the following permissions:

  • oathauth-enable
  • editinterface
  • editusercss
  • edituserjs
  • managechangetags
  • abusefilter-modify
  • autopatrol

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 12 2017, 10:37 PM

@MarcoAurelio Does this set of permissions look good to you (to be added/removed by bureaucrat/steward)?

@Gustavopedia Do you intend to write the configuration? If not, you can remove yourself from the assign field (in Add Action choose "Assign / Claim", then remove your entry). If so, you can move to the column Working on (same menu, Move on Workboard).

Dontz added a subscriber: Dontz.Apr 13 2017, 1:21 PM

waiting for the decision of all, since the bar of travelers it was decided it would be deployed to the Statute (horrible machine translation) :)

hashar removed a subscriber: hashar.Apr 13 2017, 1:25 PM

This wiki does not have local bureaucrats and I am not sure if the developers/stewards will agree that the 3 admins there can grant and remove this permission (since it allows editing the CSS and JS of the other users and the MediaWiki namespace).

We won't allow sysops assigning this right in any way. This was discussed multiple times here in Phabricator. Elect bureaucrats ;).

Yes, elect bureaucrats, what's so dangerous about giving administrators permission to remove and add this privilege? But, bureaucrats, just them.

I think the option here is to wait for Portuguese Wikivoyage to get local bureaucrats or, in its absence, to appoint the stewards to take over this permission on the wiki in the same way that is done with the administrator's permission.

In any case, the user will be asked to autocandidate, and we will evaluate the request, two possible candidates are FransciscoMG and Mr. Fulano, in which I will open the request because the two confirmed their interest in the statute. Soon after we will take the request to the stewards for them to evaluate.

Yes, elect bureaucrats, what's so dangerous about giving administrators permission to remove and add this privilege?

The editinterface right allows to provide malicious content to harm visitors.

Bureaucrats (for larger projects) and stewards (for smaller projects) role in the Wikimedia projects traditional structure is to be sure candidates are trusted by the community and are experienced to nominate to trust positions.

Dereckson renamed this task from Creating the "interface editor" permission on Wikivoyage to Creating the "interface editor" permission on Portuguese Wikivoyage.Apr 30 2017, 8:31 PM
Dereckson removed Gustavopedia as the assignee of this task.

@Dereckson Sorry for not replying to your mention above but I was away from Phabricator for some time. As we've stated several times we believe that the editinterface permission and related ones are sensitive and should only be created when a very large community exists and its management restricted to bureaucrats or stewards where present. This is clearly stated on our limits to configuration changes.

Portuguese Wikivoyage do not currently meet such requirements. There a very small community involved and at the time I write this post, there's just 6 changes in RecentChanges. The wiki do not have bureaucrats and 2 of their three administrators are temporary administrators.

As such my opinion is that this task should be declined.

Is it possible only stewards give the flag? Because the flag is useful to the users that can edit code without being a sysop.

Urbanecm closed this task as Invalid.Jul 30 2017, 11:04 AM

Sysops can't grant this right due to our limits to configuration changes. As community did not say they wish other group to be able to grant that right, closing this as invalid.