[regression wmf.21] Safari only - filter capsules with highlight displayed misalgned
Closed, ResolvedPublic

Description

On Safari 10.1:

ptwiki (wmf.21)

betalabs:

Note: FF and Chrome display filters with highlight correctly.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 2 2017, 9:59 PM
Etonkovidova updated the task description. (Show Details)May 2 2017, 10:00 PM

Bump. This is still happening.

Change 363396 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/core@master] RCFilters: Align TagItemWidget highlight in Safari

https://gerrit.wikimedia.org/r/363396

Checked https://gerrit.wikimedia.org/r/363396 -- the highlight circle is aligned properly:

Checked https://gerrit.wikimedia.org/r/363396 -- the highlight circle is aligned properly:

Way better but the text string is still not vertically centered. It seems closer to the bottom than the top. Unless that was the intended design. :)
Sorry for nitpicking!

@Niharika That's not necessarily intended design, but rather connected to T168089 and architecturally more deeper T97631. Please file another task for it or mention it on one of the two tasks.

Etonkovidova added a comment.EditedJul 7 2017, 8:37 PM

Checked with SauceLabs the following combinations and highlight with new filters look fine:

  • Windows7 + IE11, IE10, IE9
  • Windows10 + IE11
  • Windows10+ MicrosoftEdge 15

Older IE browsers (IE9 and IE8) default RC page to no-JS mode (by design).

Change 363396 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Align TagItemWidget highlight in Safari

https://gerrit.wikimedia.org/r/363396

Volker_E removed a project: Patch-For-Review.
Volker_E removed a subscriber: gerritbot.

Re-checked betalabs and plwiki (1.31.0-wmf.2) - the issue is fixed.

Etonkovidova closed this task as Resolved.Oct 11 2017, 7:15 PM