Page MenuHomePhabricator

Page jump in Minerva/mobile skin with section link or reference in URL
Closed, ResolvedPublic3 Estimated Story Points

Description

Firefox (desktop). On https://en.m.wikipedia.beta.wmflabs.org/wiki/Channel_Tunnel, I clicked the [A] link, clicked the caret to go back to [A], and then clicked reference 9. The page scrolled back to [A] for no reason, although the popup displayed. (I think this also happened on my phone earlier with a section link.)

Replication

Event Timeline

Jc86035 created this task.May 30 2017, 9:20 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 30 2017, 9:20 AM
ovasileva triaged this task as Medium priority.May 30 2017, 11:00 AM
ovasileva added a project: Readers-Web-Backlog.
ovasileva moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.

I can confirm this.

Jdlrobson added subscribers: bmansurov, Jdlrobson.EditedMay 30 2017, 2:11 PM

@bmansurov looks like we discovered what that timeout you had me remove was for... :)

Awesome. It would be great if we can document that code this time around.

Exactly my thinking!

Seems like a 1 pointer, so adding to sprint.

Jdlrobson lowered the priority of this task from Medium to Low.May 30 2017, 7:10 PM
Jdlrobson removed Jdlrobson as the assignee of this task.May 30 2017, 11:44 PM

Didn't get anywhere with this....

ovasileva raised the priority of this task from Low to Medium.May 31 2017, 11:56 AM
Jdlrobson updated the task description. (Show Details)May 31 2017, 5:13 PM
NHarateh_WMF set the point value for this task to 3.May 31 2017, 5:14 PM

Change 357333 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Don't checkHash for reference links

https://gerrit.wikimedia.org/r/357333

The issue is in the Toggler. I'm not really sure how to encapsulate it in a test. That code needs a lot of love...

Change 357333 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Don't checkHash for reference links

https://gerrit.wikimedia.org/r/357333

Jdlrobson reassigned this task from Jdlrobson to ABorbaWMF.Jun 9 2017, 4:19 PM

Can you verify the fix and do a quick check of the feature?

Tried this on a handful of devices using browserstack. All the references looked good and the [A] reference worked properly.

Tested - https://en.m.wikipedia.org/w/index.php?title=Channel_Tunnel&oldid=757761414#Passenger_traffic_volumes

Jdlrobson closed this task as Resolved.Jun 10 2017, 12:48 AM

:)