Page MenuHomePhabricator

Huggle Revert and Warn Shortcuts Wrong in Mac
Open, LowPublic

Description

On Mac in Huggle Preferences under "Shortcuts", for "main-revert-and-warn-##", the number (or N th item) is not corresponding to the correct warning. As tested today, I assigned shortcuts for "Removal of Content" and "Blanking of Page" (6 and 7) and I ended up generating warnings to users for NPOV and Reliable Sources. Huggle Version: 3.2.0 build: 3100 3.1.22-162-ga039da3

Event Timeline

Dane2007 created this task.May 31 2017, 7:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 31 2017, 7:05 PM
Petrb added a subscriber: Petrb.Jul 10 2017, 5:39 PM

Hello, this seems to be a beta version, does it happen with stable version as well?

Petrb triaged this task as High priority.Jul 10 2017, 5:40 PM

Yes, this was also happening on the stable version.

Petrb added a comment.Jul 11 2017, 8:34 PM

I can't reproduce this on other OS, so it's probably Mac related, sadly I don't have a Mac to debug this on :/

Using the dropdown menu works? Just shortcuts are wrong?

Dropdown menus seem to work fine, it just appears to be the shortcuts that are not working.

Update on this issue @Petrb - As of Huggle 3.3.0 on macOS Sierra, the shortcuts preferences no longer appear allow shortcuts to even be set (entering any command in results in no change in the preferences panel when trying to set a shortcut)

This issue remains in Huggle 3.3.4.

Petrb added a comment.May 19 2018, 9:37 AM

Works to me in 3.4.0 built with Qt 5.11

But I don't see shortcuts in menu like you say, however they work

Restricted Application added a subscriber: RichSmith. · View Herald TranscriptMay 19 2018, 9:37 AM
Petrb added a comment.May 19 2018, 9:38 AM

Keep in mind they are numbered from 0, so 3th item is item 2.

Petrb added a comment.May 19 2018, 9:48 AM

You can try here and reopen if you still have troubles https://petr.insw.cz/tmp/huggle.dmg

Petrb closed this task as Resolved.May 19 2018, 9:48 AM
Petrb claimed this task.
Dane2007 reopened this task as Open.May 23 2018, 10:16 PM

Tested with the build provided above; same issues remain unresolved.

Are you indexing the items from 0? First item in list is actually item with id 0, that's actually by design

Are you indexing the items from 0? First item in list is actually item with id 0, that's actually by design

Yes. Indexing from 0. At this point the keyboard shortcuts don't even set properly though (In preferences, when I try to add or change a shortcut, nothing happens in the box - if I type the shortcut (Ctrl+X as an example) and save, CTRL+X does nothing.

Confirmed on 3.4.1 as remaining an issue.

Confirmed on 3.4.2 as remaining an issue.

Petrb lowered the priority of this task from High to Low.Jun 10 2018, 7:29 PM

lowering priority as this seems to affect only some people (so far only Dane can reproduce this).