Page MenuHomePhabricator

Bogus "not a valid project" errors
Closed, ResolvedPublic1 Story Points

Description

Every time I try to look up my editing statistics on French Wikipedia, it tells me that "fr.wikipedia.org is not a valid project". See screenshot:

Event Timeline

kaldari created this task.Jun 22 2017, 6:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 22 2017, 6:56 PM
kaldari triaged this task as High priority.Jun 22 2017, 6:57 PM
kaldari set the point value for this task to 1.
kaldari added subscribers: Samwilson, MusikAnimal.

This is while not logged in via OAuth.

Matthewrbowker closed this task as Invalid.Jun 22 2017, 8:00 PM
Matthewrbowker added a subscriber: Matthewrbowker.

Works for me. Queries need to be optimized but that's outside of the scope of this task.

kaldari reopened this task as Open.EditedJun 22 2017, 8:50 PM

Still broken for me. Steps to reproduce:

If I try "en.wikipedia.org" it works fine, but any other wiki, like de.wikipedia.org or es.wikipedia.org causes it to give me the error consistently.

When it submits the form, it sends a request to http://xtools.wmflabs.org/api/normalizeProject/fr.wikipedia.org, which returns a 500 Internet Server error (often after waiting a long time).

Ahhhh, you were testing on the new "live" instance. I was testing on the "dev" instance, which succeeded.

I wonder what the difference is between the instances. @Samwilson you set up the OOP code correct? Do you have any thoughts here?

I think it works now (I fixed a bug in prod deployment relating to permissions on the var directory, and usage of Redis).

@Samwilson: If there are some clean-up tasks that need to be done each time the code is updated, you might want to implement a composer script. @dbarratt might also have some ideas.

Good plan. Is it okay for a composer script to call composer install? I guess so. :-)

The prod script is currently:

#!/bin/bash
export SYMFONY_ENV=prod
cd /var/www
git pull origin master
composer install --no-dev --optimize-autoloader
./bin/console cache:clear --env prod
./bin/console assetic:dump --env prod

And similar on the staging server.

(I guess T167217 is the place for that discussion though.)

kaldari closed this task as Resolved.Jun 25 2017, 11:55 PM
kaldari claimed this task.

Seems to be working now!

DannyH moved this task from Untriaged to Archive on the Community-Tech board.
MusikAnimal moved this task from Inbox to Complete on the XTools board.Jul 23 2017, 7:45 PM