Page MenuHomePhabricator

Site logo is no longer clickable in monobook
Closed, ResolvedPublic

Description

Go to https://www.mediawiki.org/w/index.php?title=Download&useskin=monobook, click the site logo (#p-logo)
Expected: you go to the main page; actual: nothing happens

Possible regression from T170053 / 909aed3: The z-index removal may have caused div#column-content to cover #p-logo.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 20 2017, 4:58 PM

Sorry. Please trout me the next time I merge a patch only because the commit message proved it was correct, without properly testing it… I tested now and that is definitely the cause.

Change 366594 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/skins/MonoBook@master] Revert "Remove position: absolute and z-index from #p-logo"

https://gerrit.wikimedia.org/r/366594

Change 366594 merged by jenkins-bot:
[mediawiki/skins/MonoBook@master] Revert "Remove position: absolute and z-index from #p-logo"

https://gerrit.wikimedia.org/r/366594

Change 366595 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/skins/MonoBook@wmf/1.30.0-wmf.10] Revert "Remove position: absolute and z-index from #p-logo"

https://gerrit.wikimedia.org/r/366595

Change 366595 merged by jenkins-bot:
[mediawiki/skins/MonoBook@wmf/1.30.0-wmf.10] Revert "Remove position: absolute and z-index from #p-logo"

https://gerrit.wikimedia.org/r/366595

Mentioned in SAL (#wikimedia-operations) [2017-07-20T18:24:22Z] <thcipriani@tin> Synchronized php-1.30.0-wmf.10/skins/MonoBook/main.css: SWAT: [[gerrit:366595|Revert "Remove position: absolute and z-index from #p-logo"]] T171195 (duration: 00m 47s)

matmarex closed this task as Resolved.Jul 20 2017, 6:45 PM
matmarex claimed this task.
matmarex removed a project: Patch-For-Review.

Fixed and deployed.

First idea without intense testing: Using position: relative; instead with z-index.