Page MenuHomePhabricator

Allow timezone to be global
Closed, ResolvedPublic2 Story Points

Description

The timecorrection preference on Special:GlobalPreferences currently doesn't have a globalize-this checkbox, but it should.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 31 2017, 1:42 AM
kaldari triaged this task as Normal priority.Aug 2 2017, 12:02 AM
kaldari edited projects, added Community-Tech-Sprint; removed Community-Tech.
kaldari set the point value for this task to 2.
MaxSem claimed this task.Aug 4 2017, 11:40 PM
MaxSem moved this task from Ready to In Development on the Community-Tech-Sprint board.

This is caused by preferences that set 'class' instead of 'type'. On enwiki, there are 12 such preferences (some of them are just UI elements):

NameClassComments
timecorrection (which this bug requests)HTMLSelectOrOtherFieldshould be global
cirrussearch-pref-completion-profileCirrusSearch\HTMLCompletionProfileSettingsshould be global
betafeatures-section-descHTMLTextBlockFieldignore
betafeatures-auto-enrollNewHTMLCheckFieldshould be global
betafeatures-breaking-hrHTMLHorizontalRuleFieldignore
several beta feature checkboxesHTMLFeatureFieldshould be global
echo-subscriptionsHTMLCheckMatrixshould be global

echo-subscriptions is extremely problematic because it's a composite form element representing multiple preferences that are stored separately.

I think I'm going to create a whitelist of classes for now. Not sure what to do about Echo preferences though, will open a separate bug for it.

Change 370304 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[mediawiki/extensions/GlobalPreferences@master] Globalize preferences that specify class instead of type

https://gerrit.wikimedia.org/r/370304

MaxSem added a comment.Aug 5 2017, 2:09 AM

The above patch fixes the issue wherever possible, however highlight on hover doesn't work for BetaFeatures checkboxes because of oojas trickery.

Patch looks good to me. The OOJS stuff can be tackled in the UI work of T68869.

Change 370304 merged by jenkins-bot:
[mediawiki/extensions/GlobalPreferences@master] Globalize preferences that specify class instead of type

https://gerrit.wikimedia.org/r/370304

Samwilson closed this task as Resolved.Aug 31 2017, 2:58 AM
Samwilson moved this task from In Development to Q1 2018-19 on the Community-Tech-Sprint board.
DannyH moved this task from Untriaged to Archive on the Community-Tech board.Sep 15 2017, 9:23 PM