Page MenuHomePhabricator

Wikipedia main portal shown in English instead of Arabic language on an Arabic system
Closed, DeclinedPublic

Description

Hello, some users in arwiki asked us about the language of Wikipedia main portal
For example, it's appear to me in Arabic language but appear to other users in arwiki in English!

So How we can change the language of this portal? We try to change the language of the browser or to add (uselang=ar) but it didn't work!

Event Timeline

Restricted Application added a project: Discovery. · View Herald TranscriptAug 29 2017, 12:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
alanajjar updated the task description. (Show Details)Aug 29 2017, 12:52 PM
Meno25 updated the task description. (Show Details)Aug 29 2017, 1:19 PM

@alanajjar www.wikipedia.org should change languages when you change the language of the browser. This functionality should work in all modern browsers. Below is a video of how I change the browser language in firefox to Arabic and the portal changes. If you can provide any more details about what browsers this doesn't work in (or share the video below to the users having this issue) that would be great. Thanks.

Thanks @Jdrewniak

I posted what you said in arwiki village pump. If f there's any new details from ar-users I'll open it again.

alanajjar closed this task as Resolved.Aug 29 2017, 2:55 PM
alanajjar reopened this task as Open.Aug 29 2017, 8:31 PM

@Jdrewniak as mentioned here one of arwiki user try to change the language of the browser but the language still in English. He uploaded a picture. He is using Chrome browser.

Note that he is the first one who asked about these thing in arwiki.

debt added a subscriber: debt.EditedAug 30 2017, 8:50 PM

Hi @alanajjar - I'm not able to reproduce what is going on with the other user on arwiki. Here are my screen shots of changing the language in Chrome and then visiting the wikipedia.org portal page. I've posted a link to this edit on the arwiki page.


alanajjar closed this task as Resolved.Aug 30 2017, 8:52 PM
debt awarded a token.Aug 30 2017, 8:53 PM
David added a subscriber: David.EditedOct 29 2017, 12:28 PM

@debt The error was corrected in Chrome on the computer, but what about Chrome on the phone? I use Android in Arabic (Phone item:https://www.wikidata.org/wiki/Q15978789), but the Arabic translation does not appear, what's the solution?Thank you

David reopened this task as Open.Oct 29 2017, 12:30 PM
Aklapper renamed this task from Wikipedia main portal to Wikipedia main portal shown in English instead of Arabic language on an Arabic system.Oct 29 2017, 2:18 PM

Not sure why @alanajjar closed this task as "resolved" when there was no code change that changed something...?

@David: Please see https://phabricator.wikimedia.org/T174434#3561974 how to provide sufficient and clear information, to allow developers to investigate.

David added a comment.Oct 29 2017, 2:25 PM

@debt The translation does not appear in Android

@David: Which browsers and which browser versions did you test on which Android versions? Please see https://mediawiki.org/wiki/How_to_report_a_bug

I was able to produce the arabic version of the page on mobile by going to system settings on Android and changing the language to Arabic.
However, in the process I discovered a rendering bug T179273 :(

debt added a comment.Oct 30 2017, 9:02 PM

Hi @David - please let us know how to reproduce what you're seeing on your android device; screenshots are also nice to have. :)

@Aklapper I believe that this ticket was closed earlier by @alanajjar because there wasn't a bug, as I described in my response: T174434#3567944, I believe that they weren't setting their browser preferred language correctly.

debt closed this task as Declined.Nov 21 2017, 6:38 PM

I'll close this out, as it was probably due to user error.