Special:ContentTranslation page: Mobile UI layout issues
Closed, ResolvedPublic

Description

Ellipsis for article description truncation: (tracked at T182479)

  • an extra dot in the description of 'Roger Norreis' article
  • the ellipsis for the 'Georgina Chapman' article description are placed far way from the actual description. The screenshot below illustrates another problem with the ellipsis - the dotdotdot are too close.


  • the X icon (and sometime the star icon) overlaps the article titles.

  • Long words in article titles overflow

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 27 2017, 7:13 AM
Etonkovidova renamed this task from Special:ContentTranslation page: Mobile UI layout to Special:ContentTranslation page: Mobile UI layout issues.Oct 27 2017, 7:15 AM
Etonkovidova closed this task as Resolved.

Change 396309 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Break overflowing words

https://gerrit.wikimedia.org/r/396309

Most of the problems were caused by too big space around actual content. That space is made smaller on mobile screens when T178669 was resolved. Allowing more space resolves almost all of the issues described, with few edge-cases.
I have published a patch to deal with points (2) and (3) described in this ticket.

Point "(1) Ellipsis for article description truncation" should be fixed after removal of justified description, which is tracked at T182479, so I will consider that point a separate ticket.

Change 396309 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Break overflowing words

https://gerrit.wikimedia.org/r/396309

Checked in wmf.12 - the Special:ContentTranslation page looks much more balanced in terms of icons vs text positioning. Small adjustments may be made if specific issues will arise.

Etonkovidova closed this task as Resolved.Dec 15 2017, 2:12 AM
Nikerabbit moved this task from QA to Done on the Language-2017-Oct-Dec board.Dec 15 2017, 7:55 AM