Page MenuHomePhabricator

Many translations for 'createacct-helpusername-url' are missing
Closed, ResolvedPublic

Description

Many translations for the message 'createacct-helpusername-url' (from the WikimediaMessages extension) are missing on Wikimedia wikis, even though they exist on Translatewiki.

For example:

Other languages are not affected (e.g. de and es).

This causes the "(help me choose)" link on the signup form (https://en.wikipedia.org/wiki/Special:CreateAccount) on wikis in that language to lead to a non-existent page (at least until the message is overridden locally, or a redirect from the English title is created).

Event Timeline

matmarex created this task.Oct 31 2017, 2:31 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 31 2017, 2:31 AM

Looks like l10n-bot has removed this message (and several others) from many JSON files in i18n/wikimedia/ in 0f3c6c9d83d3dcbda5cf545ba116d35f2d0cea90… in some languages, it was added to the JSON files in i18n/wikimediaoverrides/ instead, but only in some. I suppose rEWME80cd8c440fae: Move overrides to wikimediaoverrides json files (en.json and qqq.json) might be the root cause of this behavior?

@Raymond Can we do a full export from Translatewiki for this extension?

Actually, this has been broken for a while, probably shouldn't be a release blocker…

That restored a few languages (it, et, pl), but many more are still missing (e.g. he). Searching for "createacct-helpusername-url" in the repository gives 24 results, while https://translatewiki.net/wiki/Special:PrefixIndex/MediaWiki:createacct-helpusername-url/ has 58. Do you have any idea why the missing translations would not be exported?

Weird.... In translatewiki config the message get a prefix because it seem to exist in core. But it this still true? I cannot find it in Core per grep.

Furthermore: Translating via translatewiki does not add the wmf- prefix. Maybe this is the problem?

If this message is not longer part of core or other extensions I can remove the prefix and I guess that the problem will be fixed..

I did some history digging and it used to be in core, but was removed ages ago. See https://gerrit.wikimedia.org/r/#/c/61395/ and https://gerrit.wikimedia.org/r/#/c/62570/.

Wargo added a subscriber: Wargo.Nov 2 2017, 8:55 PM

I think it is because some translations are marked as "FUZZY" because of "Namespace changed from the definition". Try to confirm it and wait for next update.

Any updates on this: is the issue still present? Is help needed to debug this?

matmarex closed this task as Resolved.Dec 4 2017, 9:43 PM

Looks like some other missing messages were restored in 8830e6fe63fa4ee2ec71eddb195b5c32eb7ed6bd. Possibly Raymond made it work with 31705b897594f7dd37572a340814e5174a1553e6? Looks like the message is now present in the repository in all 58 languages, so this seems fixed.