Page MenuHomePhabricator

Reply to/ping feature problem in arwiki
Closed, ResolvedPublic

Description

Hello as a complete of our discussion with @Trizek-WMF I opened this ticket.

Summary
Many users in ar.wikipedia complain from a problem in Reply to/ping feature, we tried to fix it many times but we have not succeeded. Also Notification of Failed/Successful mention didn't work!

So, what we can do? Is there a mistake/s on the unit or on the template itself, or what?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 28 2017, 2:33 PM
alanajjar updated the task description. (Show Details)Nov 28 2017, 2:34 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptNov 28 2017, 2:46 PM

@Reedy yeah it's work sometimes until now!

@Reedy yeah it's work sometimes until now!

What do expect then? Some advice to fix it? Or an alternative to it? :)

@Trizek-WMF I saw that the template not using the unit, while the en. one using it (and here on Meta the same).

What do you mean by "the unit"?

For what I understand (it is very difficult to translate parameters from Arabic language), the template you have now is supposed to work. I don't see any connexion between that template and the module.

If you want to use the module, the template must call the module.

I advise you to:

  1. check if the module is exactly the same as on meta or English Wikipedia
    1. if not, copy it to your wiki with the same name 'reply to'
  2. copy the content of one of the templates you mention to a test template your wiki with no changes
  3. check if it works better with that test template.
1339861mzb added a comment.EditedNov 28 2017, 11:16 PM

@Trizek-WMF I updated the module to be compatible with enwiki one. Regarding the name of thr module did you advice to use English in the title i.e reply to instead of Arabic one (رد على) ?

This comment was removed by 1339861mzb.

@Trizek-WMF I updated thr module to be compatible with enwiki one. Regarding the name of thr module did you advice to use english in the title i.e reply to instead of arabic one (رد على) ?

Yes. That way, you can make a safe test. When it will be working, you can rename it.

For what I understand (it is very difficult to translate parameters from Arabic language), the template you have now is supposed to work. I don't see any connexion between that template and the module.
If you want to use the module, the template must call the module.
I advise you to:

  1. check if the module is exactly the same as on meta or English Wikipedia
    1. if not, copy it to your wiki with the same name 'reply to'
  2. copy the content of one of the templates you mention to a test template your wiki with no changes
  3. check if it works better with that test template.

Done. I'll try if there's any improvement.

@Trizek-WMF I saw also that mention feature and its notification works well in commons

And if we take a look at the template source in commons, we'll find that it's the same of previous one that used in arwiki (It's doesn't use Module:Replay to)

@Trizek-WMF I updated thr module to be compatible with enwiki one. Regarding the name of thr module did you advice to use english in the title i.e reply to instead of arabic one (رد على) ?

Yes. That way, you can make a safe test. When it will be working, you can rename it.

done by alanajjar. to me even after updating the module and the template on arwiki there is some notifications still does not reach to me

@Trizek-WMF @Reedy I think I (with user:SR5) found the problem. I'll clarify after another additional experiences.

And if we take a look at the template source in commons, we'll find that it's the same of previous one that used in arwiki (It's doesn't use Module:Replay to)

Correct.
There is two ways to have that template working:

  1. use the Module and #invoke it in the template. You have then to be careful on how you connect the first one with the second one.
  2. create an old-style template with parameters that will create something like [[user:{{{1|}}}|{{{1|}}}]]

Both are not compatible to each other.

@Trizek-WMF @Reedy I think I (with user:SR5) found the problem. I'll clarify after another additional experiences.

Great! :)
What was it?

And if we take a look at the template source in commons, we'll find that it's the same of previous one that used in arwiki (It's doesn't use Module:Replay to)

Correct.
There is two ways to have that template working:

  1. use the Module and #invoke it in the template. You have then to be careful on how you connect the first one with the second one.
  2. create an old-style template with parameters that will create something like [[user:{{{1|}}}|{{{1|}}}]]

Both are not compatible to each other.

@Trizek-WMF @Reedy I think I (with user:SR5) found the problem. I'll clarify after another additional experiences.

Great! :)
What was it?

most likely the using of signature templates which does not appear in the wiki text as direct link to the user talkpages

1339861mzb added a comment.EditedNov 29 2017, 7:20 PM

i.e referring to your note :

Quoted Text

Sign your comment with ~~~ or ~~~~. Notifications will not be sent if your signature is embedded in a template, or has no link to your user page or user talk page.

the problem is that many users in arwiki use signatures which is embedded in a template like this {{مستخدم:علاء/توقيع}} which literally corresponds in English language to {{user:علاء/signature }}.

In other words; users in arwiki usually use signatures which is embedded in a template without using Substitution in signing them i.e they depend on mirroring of their sugniture pages.

alanajjar closed this task as Resolved.Nov 30 2017, 11:35 AM
alanajjar claimed this task.

I created a page with all things related to ping template (In ar.wiki) - def., uses, instructions and other information.