Page MenuHomePhabricator

Pasting HTML in NWE can't be undone via keyboard
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Open a page for editing in NWE.
  2. Copy from any article some HTML with a link.
  3. Paste in NWE. As expected the content is transformed into wiki syntax.
  4. Press Ctrl-Z.

Expected: The pasted content is removed again.
Actual: Nothing happens.

Undoing via toolbar works, undoing via keyboard for pastes without conversion works, too.
I tested in Firefox, both de.wikipedia.org and de.wikipedia.beta.wmflabs.org.

Event Timeline

Schnark created this task.Dec 8 2017, 11:03 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptDec 8 2017, 11:03 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Looks like selection is getting restored correctly after async paste.

Change 397862 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Only resolve wikitext promise when progress dialog has closed

https://gerrit.wikimedia.org/r/397862

Deskana assigned this task to Esanders.Dec 12 2017, 7:58 PM
Deskana triaged this task as Normal priority.
Deskana moved this task from To Triage to TR1: Releases on the VisualEditor board.
Deskana set the point value for this task to 1.

Change 397862 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Only resolve wikitext promise when progress dialog has closed

https://gerrit.wikimedia.org/r/397862

Deskana closed this task as Resolved.Apr 18 2018, 11:19 AM