Page MenuHomePhabricator

mw-page-header-links take empty space on special pages
Closed, ResolvedPublic

Description

Since there doesn't seem to be any visible links this could be avoided with something like

.ns-special #mw-page-header-links { display: none; }

The empty is zero-height, but it will still cause extra space because it triggers margins.

Event Timeline

Hi there.
I was not able to reproduce the error in my local vagrant setup.
I went to http://127.0.0.1:8080/wiki/Special:SpecialPages in my local environment.
If it's still a bug, can you please provide me the php and css files related to that page.
Peace .

Did you use the Timeless skin?

Himanshuc3 added a comment.EditedJan 10 2018, 7:54 AM

I've enabled it through roles.
Do I need to set it up somewhere?

Edit: Nevermind, applied it. :)

OK. So I think I have solved it.
I've worked with GitHub but I think this is gonna be a little different.
Can you tell me how to submit a patch to this.
The changes would be made to the timeless skin.
Peace.

Hi, please see https://www.mediawiki.org/wiki/How_to_become_a_MediaWiki_hacker

It contains links to pages that explain how to use Gerrit as well as other general guidance like where to ask for help. Phabricator is not a good place to ask for help about issues that are not specific to the task at hand.

Change 403466 had a related patch set (by Himanshuc3) published:
[mediawiki/vagrant@master] BUG: T182533 Removes extra whitespace in timeless skin.

https://gerrit.wikimedia.org/r/403466

https://gerrit.wikimedia.org/r/#/c/403465/1
Line 200: made the edit.
I am a Beginner, so you can feel free to tell me what I did wrong or should be done in future PRs.
PEACE OUT.

https://gerrit.wikimedia.org/r/#/c/403586/
Can you please review that. It will be very helpful of you.

Change 403466 abandoned by Thiemo Kreuz (WMDE):
BUG: T182533 Removes extra whitespace in timeless skin.

Reason:
There is no code in this patch, and no further action for several months.

https://gerrit.wikimedia.org/r/403466

Change 403586 had a related patch set uploaded (by Himanshuc3; owner: Himanshuc3):
[mediawiki/skins/Timeless@master] Empty space in Special Pages removed

https://gerrit.wikimedia.org/r/403586

Change 407886 had a related patch set uploaded (by Himanshuc3; owner: Himanshuc3):
[mediawiki/skins/Timeless@master] Empty space in Special Pages removed

https://gerrit.wikimedia.org/r/407886

Evad37 added a subscriber: Evad37.Apr 30 2018, 4:06 AM

What's happening here is that the empty portlets p-namespaces and p-views still take up space because they are styled with display: inline-block.

  • p-namespaces has class emptyPortlet which sets display: none, but it doesn't have any effect because the css rule (in screen-common.less) hasn't got enough specificity
  • p-views doesn't have class emptyPortlet, because it isn't actually empty: it contains a dropdown toggle (ca-more) which is hidden in desktop views (by screen-desktop.less)

Perhaps the ca-more dropdown toggle should go into its own portlet, so that p-views will actually be empty on special pages.

Change 429743 had a related patch set uploaded (by Evad37; owner: Evad37):
[mediawiki/skins/Timeless@master] Fix hiding of empty portlets on special pages

https://gerrit.wikimedia.org/r/429743

Change 429743 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Fix hiding of empty portlets on special pages

https://gerrit.wikimedia.org/r/429743

Change 407886 abandoned by Isarra:
Empty space in Special Pages removed

Reason:
Superseded by other patch. Issue seems resolved; thank you both of you.

https://gerrit.wikimedia.org/r/407886

Evad37 closed this task as Resolved.May 7 2018, 3:51 AM
Evad37 claimed this task.

Change 403586 abandoned by Isarra:
Empty space in Special Pages removed

Reason:
Has sat here for a year; if there's something to be done now, feel free to come back to it, but I doubt this still applies anyhow?

https://gerrit.wikimedia.org/r/403586