Page MenuHomePhabricator

[betalabs] Drop-down filter menu becomes detached when the first filter item is selected
Closed, ResolvedPublic

Description

Two different scenarios.

Chrome

  1. On RC page with the new filters clear all the filters.
  2. Click in the filter search area and select the first filter : Very likely good
  3. Without clicking anywhere else - move your mouse cursor outside the drop-down filter area.

The drop-down filter becomes deatached.

The console displays (may be irrelevant):

PopupWidget#toggle: Before calling this method, the popup must be attached to the DOM.
JQMIGRATE: jQuery.fn.offset() requires an element connected to a document

Firefox
The same steps as above - but the drop down menu is simply disappears when the selection of 'Very likely good' is made:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 21 2017, 1:37 AM

I can't reproduce this, but I have a feeling this has to do with the lazy loading. @Etonkovidova can you confirm, though -- between step 1 and step 2, the popup should open automatically. When you "clear" the filters, the input should be focused, and the popup should open. Is that happening? I just want to verify.

I couldn't reproduce in Mac Chrome or Firefox

Yes, it's not reproducible now due to two factors

  • betalabs kicks the user out of session with the increased frequency - every couple of seconds
  • Damaging filters are missing from the drop down filters

I will re-check later, but I suspected from the beginning that it's not a true bug.

SBisson added a subscriber: SBisson.EditedDec 22 2017, 11:36 AM

I can reproduce it.

  1. Go to Special:RC and make sure you have a long list of changes
  2. Open the menu and select a filter that will make the list very short or empty
  3. Wait for the results (or no results) to load
  4. Unselect the filter from #2
  5. Wait for the results to load and see the menu being dragged down the page
  6. (It re-attaches as soon as you start scrolling)

Change 399802 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/skins/Vector@master] Fix detached RCFilters menu

https://gerrit.wikimedia.org/r/399802

Change 399802 merged by jenkins-bot:
[mediawiki/skins/Vector@master] Fix detached RCFilters menu

https://gerrit.wikimedia.org/r/399802

Etonkovidova closed this task as Resolved.Dec 26 2017, 1:43 AM
Restricted Application added a project: Growth-Team. · View Herald TranscriptAug 20 2018, 2:28 PM