Page MenuHomePhabricator

GettingStarted on other pages: Use flexible width for dialog if possible
Closed, ResolvedPublic

Description

Reported by @Etonkovidova

The first screenshot (with a bulb) will get a horizontal scrollbar when a user increases the screen font slightly.

Expected result:
Dialog should feature flexible width instead of fixed one and grow slightly with its content

After patch:

Event Timeline

Volker_E triaged this task as High priority.Dec 21 2017, 11:24 PM
Volker_E created this task.

Change 399757 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/GettingStarted@master] Replace width by min-width for other pages dialog

https://gerrit.wikimedia.org/r/399757

Volker_E updated the task description. (Show Details)Dec 21 2017, 11:39 PM

@Etonkovidova You've said, it was Chrome 63 with slightly increased font-size? How did you increase it? For me with 110%-200% I don't get a scrollbar on OS X.

Change 399757 merged by jenkins-bot:
[mediawiki/extensions/GettingStarted@master] Replace width by flexible solution for other pages dialog

https://gerrit.wikimedia.org/r/399757

Etonkovidova added a comment.EditedDec 22 2017, 4:48 PM

@Volker_E Cmd+ to increase. With &gettingStartedReturn=true, it requires two steps up to see the horizontal scroll bar (from today's betalabs):

After 399757 got merged:


at 200%.

No scrollbar visible in Chrome 63?! @Etonkovidova

Etonkovidova added a comment.EditedDec 26 2017, 1:55 AM

@Volker_E

  • with a new user first time logged in betalabs (gettingStartedReturn=true will be displayed in the url), the popup is as the following:
  • and, yes, I should've been more specific: Chrome 63, full-size, 125% gives the horizontal scroll bar. Other increases - 110% and 150 - will not display the scroll bar.
Volker_E closed this task as Resolved.Dec 26 2017, 5:46 AM

Ok, Chrome 63 @ 125% for me


I honestly prefer to resolve this task, the specific scrollbar is not intended, but not reproducible for me. The smaller dialog should be flexible to width overflowing.
Even in the latest described case, it doesn't really interrupt users and also only seems to appear on a very specific setting.
Let's reopen when necessary.

Volker_E raised the priority of this task from High to Needs Triage.Mar 17 2018, 8:07 PM
Volker_E moved this task from Backlog to Done on the UI-Standardization-Kanban board.
Volker_E removed a project: Patch-For-Review.
Volker_E removed a subscriber: gerritbot.