Page MenuHomePhabricator

Provide link to (visual?) diff caused by lint errors
Closed, ResolvedPublic

Description

I believe it would be useful if pages such as Special:LintErrors/tidy-font-bug provided some link for users to see what would change in the pages in case the error were not fixed. Currently, since "it works", they may fell less motivated to fix the errors

Event Timeline

He7d3r created this task.Dec 28 2017, 1:24 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 28 2017, 1:24 PM

For cases where Remex changes the rendering, the "edit" link uses the ParserMigration tool that will show a diff of the current rendering, and the future broken rendering... - @ssastry should tidy-font-bug be using parser migration?

For cases where Remex changes the rendering, the "edit" link uses the ParserMigration tool that will show a diff of the current rendering, and the future broken rendering... - @ssastry should tidy-font-bug be using parser migration?

Yes, and looks like the edit links anywhere actually aren't showing the parser migration links ... something is broken.

For cases where Remex changes the rendering, the "edit" link uses the ParserMigration tool that will show a diff of the current rendering, and the future broken rendering... - @ssastry should tidy-font-bug be using parser migration?

Yes, and looks like the edit links anywhere actually aren't showing the parser migration links ... something is broken.

I am not sure if they ever did -- I noticed this earlier this month and meant to investigate it, but got distracted. I am heading off on a trip shortly, so will have to wait till Jan unless @Legoktm, you can take a look.

Izno added a subscriber: Izno.May 1 2018, 1:29 AM

There were never parser-migration edit links in this context, only the linterid edit links.

Change 430026 had a related patch set uploaded (by Subramanya Sastry; owner: Subramanya Sastry):
[mediawiki/extensions/Linter@master] Fix broken test for enabling parsermigration-edit links

https://gerrit.wikimedia.org/r/430026

Change 430026 merged by jenkins-bot:
[mediawiki/extensions/Linter@master] Fix broken test for enabling parsermigration-edit links

https://gerrit.wikimedia.org/r/430026

ssastry closed this task as Resolved.Mar 11 2019, 4:43 PM
ssastry claimed this task.