Page MenuHomePhabricator

jquery.wikibase.entityview.js should not use deprecated jQuery.expr[':']
Closed, ResolvedPublic

Description

Event Timeline

He7d3r created this task.Jan 24 2018, 9:53 AM
Restricted Application added a project: Wikidata. · View Herald TranscriptJan 24 2018, 9:53 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Lucas_Werkmeister_WMDE closed this task as Resolved.Jun 18 2019, 2:55 PM
Lucas_Werkmeister_WMDE claimed this task.

This was fixed in Wikibase a while ago with Iefeaad9751 and Iab2227fbd4 – I wasn’t aware of this task at the time, otherwise I would’ve mentioned it in the commit message.

I still see the warning on Wikidata, but I’m not sure where it’s coming from. MediaWiki code search finds no other occurrences that look relevant to Wikidata. Gadget-SiteIdToInterwiki.js still uses the deprecated form, but I can also see the warning in a private window, where the gadget shouldn’t be enabled. Any other ideas?

That said, since this task is specific to jquery.wikibase.entityview.js, I think it’s okay to close it.