Page MenuHomePhabricator

[Bug] Special:SetSiteLink shows the form twice after an error
Closed, ResolvedPublic

Description

Special:SetSiteLink contains the form twice when showing an error message after an error:

Details

Related Gerrit Patches:
mediawiki/extensions/Wikibase : masterAdd missing return to SpecialModifyEntity

Event Timeline

Fomafix created this task.Feb 8 2018, 12:56 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptFeb 8 2018, 12:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 410213 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/Wikibase@master] Add missing return to SpecialModifyEntity

https://gerrit.wikimedia.org/r/410213

thiemowmde triaged this task as Medium priority.
thiemowmde moved this task from incoming to ready to go on the Wikidata board.
thiemowmde added a project: good first task.
thiemowmde added subscribers: thiemowmde, daniel.

I was able to reproduce the error quite easily by temporarily adding return Status::newFatal( 'dummy' ); to SpecialWikibaseRepoPage::saveEntity, and simulating an error that way. The same issue with the duplicate form then appears in all special pages that are based on the same abstract class: Special:SetLabel, description, aliases, and sitelinks.

Zoranzoki21 moved this task from Backlog to Doing on the good first task board.May 17 2018, 4:34 PM

Change 410213 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Add missing return to SpecialModifyEntity

https://gerrit.wikimedia.org/r/410213

Addshore closed this task as Resolved.Sep 18 2018, 12:07 PM
Addshore added a subscriber: Addshore.

It looks like this is fixed