Page MenuHomePhabricator

The filters menu is closed when a filter colour is selected
Closed, InvalidPublic

Description

Having to open the menu each time a new colour is selected can be annoying for the user, especially since you also lose your position in the filter list. This was part of the feedback from when ORES was enabled on svwp, source: https://sv.wikipedia.org/wiki/Wikipedia:Bybrunnen#Synpunkter_p%C3%A5_anv%C3%A4ndargr%C3%A4nssnittet.

Steps to reproduce:

  1. On a wiki with the extension enabled (eg. enwp), go to recent changes.
  2. Click "Filter changes [...]".
  3. Enable "Highlight results".
  4. Click the colour dropdown for a filter, select a colour.

Actual result:
The "Filters" menu is closed.

Expected result:
Leave the menu open, allowing the user to select colours for multiple filters.

Additional information:
It's not clear if this is a bug or feature request. The behaviour is reproducible in Firefox (58.0.2) and Chrome (64.0.3282.186).

Event Timeline

Restricted Application added a project: Machine Learning Platform. · View Herald TranscriptMar 5 2018, 11:23 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Larske added a subscriber: Larske.Mar 5 2018, 4:57 PM
Etonkovidova closed this task as Invalid.Apr 10 2018, 11:34 PM
Etonkovidova added a subscriber: Etonkovidova.

The only way to dismiss the drop-down filter selection panel is to click outside the panel. I checked the steps described in the ticket in svwiki, enwiki, and betalabs wiki and after step #4 the filter panel remains open. It could be that some improvements made to the filters UI behavior resulted in resolving the issue.

@Sebastian_Berlin-WMSE could you re-check if the issue is still present (there could be a chance there are some details that I missed)? I closed the ticket as 'Invalid' because the issue seems not existing anymore.

You're right, this works as it should now. Thanks for looking into it, @Etonkovidova.