Page MenuHomePhabricator

Grey lines appearing while scrolling up the 2010 wikitext editor window with a scroll wheel under Timeless skin in IE11
Closed, ResolvedPublic

Description

I tested the Timeless skin at IE11 while using one of old WikiEditors. The editing and the skin function all right in IE11. One issue while editing a page under the Timeless skin is seeing grey lines while I scroll up the editing window of one of old WikiEditors 2010 wikitext editor.

UPDATE:

Event Timeline

gh87 created this task.Mar 29 2018, 7:44 AM

Is that line about text field? i.e. have you clicked that grey line to try typing some texts?

gh87 added a comment.Mar 29 2018, 3:01 PM

Oh yeah... Almost forgot. When I click the text field, or when I type something, the grey lines disappear. The lines reappear when I scroll up the field.

Isarra added a subscriber: Isarra.Aug 16 2019, 8:59 PM

Is this still happening? I don't wanna install IE, but I probably could to actually look into fixing this, if it still needs it.

gh87 added a comment.Aug 16 2019, 10:56 PM

If you use the IE11 on either Windows 7, 8 or 10 (if 10, then enable IE11 via Edge), and if you enable the 2010 wikitext editor, you scroll up the editor and then see the grey lines. The grey lines immediately disappear when you move the mouse cursor or scroll down the editor.

Here's the screenshot:

gh87 renamed this task from Grey lines appearing while scrolling up one of old WikiEditor windows with a scroll wheel under Timelines skin in IE11 to Grey lines appearing while scrolling up the 2010 wikitext editor window with a scroll wheel under Timelines skin in IE11.Aug 16 2019, 10:58 PM
gh87 updated the task description. (Show Details)

All right, thanks. I'll look into this.

Also seriously what is the world coming to when working on IE bugs seems like a relaxing change of pace...

All right, can definitely reproduce on windows 7, but IE's dev tools are all broken, so I'm a bit limited at the moment...

(Can't reproduce on windows 10 because IE11 on that one seems to have decided it's actually IE6 and has refused to load half the stylesheets and any js. But the entire OS on that one is a bit fried, so I'm not going to read into that.)

Isarra added a comment.EditedAug 17 2019, 1:00 AM

It appears this is caused by an interaction between the Timeless text area box shadows and the WikiEditor toolbar styling. They're both fine by themselves.

gh87 renamed this task from Grey lines appearing while scrolling up the 2010 wikitext editor window with a scroll wheel under Timelines skin in IE11 to Grey lines appearing while scrolling up the 2010 wikitext editor window with a scroll wheel under Timeless skin in IE11.Aug 17 2019, 1:32 AM

Change 530650 had a related patch set uploaded (by Isarra; owner: Isarra):
[mediawiki/skins/Timeless@master] Fixes for IE11 and 9 too because fine we're going there and it's two lines

https://gerrit.wikimedia.org/r/530650

Change 530650 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Fix weird lines appearing in IE with Extension:WikiEditor

https://gerrit.wikimedia.org/r/530650

Isarra closed this task as Resolved.Aug 28 2019, 6:52 PM
Isarra claimed this task.
gh87 reopened this task as Open.Aug 30 2019, 11:29 PM

Sorry, but the gerrit code didn't fix the problem. The issue still persists as seen below:

It won't actually hit enwp until the third or the fifth, based on the patch notes.

Izno added a subscriber: Izno.Aug 30 2019, 11:45 PM

Sorry, but the gerrit code didn't fix the problem. The issue still persists as seen below:

Issues are resolved when fully merged, not when deployed.

Izno closed this task as Resolved.Aug 30 2019, 11:45 PM