Page MenuHomePhabricator

Visual editor's "leave feedback about this software" doesn't open
Closed, ResolvedPublic

Description

When I click "leave feedback about this software" nothing happens.
I can reproduce this on all wikis, logged in and logged out.
I have Firefox 59 on Windows 10.

I can see the following message on the log:

jQuery.Deferred exception: this.toolbar.getSurface is not a function ve.ui.MWHelpPopupTool.prototype.onFeedbackClick/this.feedbackPromise<@https://en.wikipedia.org/w/load.php?debug=false&lang=en&modules=diffMatchPatch%2Cmoment%2Coojs-ui%2Coojs-ui-core%2Coojs-ui-toolbars%2Coojs-ui-widgets%2Coojs-ui-windows%2Cpapaparse%2Crangefix%2Cspark-md5%2CtreeDiffer%2Cunicodejs%7Cext.CodeMirror.data%2Clib%2CvisualEditor%7Cext.CodeMirror.mode.mediawiki%7Cext.CodeMirror.visualEditor.init%7Cext.centralauth.ForeignApi%7Cext.cite.style%2CvisualEditor%7Cext.cite.visualEditor.core%2Cdata%2Cicons%7Cext.citoid.visualEditor%7Cext.citoid.visualEditor.data%7Cext.disambiguator.visualEditor%7Cext.geshi.visualEditor%7Cext.graph.data%2CvisualEditor%7Cext.kartographer%2CtemplateData%7Cext.kartographer.editing%2CvisualEditor%7Cext.math.styles%2CvisualEditor%7Cext.score.visualEditor%7Cext.templateData.images%7Cext.templateDataGenerator.data%2CeditPage%2Cui%7Cext.templateDataGenerator.ui.images%7Cext.visualEditor.articleTarget%2Cbase%2Ccore%2Cdata%2CdesktopArticleTarget%2CdesktopTarget%2Cdiffing%2Cicons%2Clanguage%2Cmediawiki%2CmoduleIcons%2Cmwalienextension%2Cmwcore%2Cmwdiffing%2Cmwextensionmessages%2Cmwextensions%2Cmwformatting%2Cmwgallery%2Cmwimage%2Cmwlanguage%2Cmwlink%2Cmwmeta%2Cmwsignature%2Cmwtransclusion%2Cswitching%2Cwelcome%7Cext.visualEditor.core.desktop%7Cext.visualEditor.mwextensions.desktop%7Cext.visualEditor.mwimage.core%7Cext.wikihiero.visualEditor%7Cjquery.lengthLimit%7Cmediawiki.ForeignApi%2CForeignStructuredUpload%2CForeignUpload%2CUpload%2Cwidgets%7Cmediawiki.ForeignApi.core%7Cmediawiki.ForeignStructuredUpload.BookletLayout%2Cconfig%7Cmediawiki.Upload.BookletLayout%7Cmediawiki.action.view.redirectPage%7Cmediawiki.api.edit%2Cmessages%2Cupload%7Cmediawiki.diff.styles%7Cmediawiki.language.names%7Cmediawiki.libs.jpegmeta%7Cmediawiki.page.gallery.styles%7Cmediawiki.skinning.content.parsoid%7Cmediawiki.widgets.CategoryMultiselectWidget%2CDateInputWidget%2CMediaSearch%2CStashedFileWidget%2CUserInputWidget%2Cstyles%7Cmediawiki.widgets.DateInputWidget.styles%7Coojs-ui-core.styles%7Coojs-ui.styles.icons-accessibility%2Cicons-alerts%2Cicons-content%2Cicons-editing-advanced%2Cicons-editing-core%2Cicons-editing-list%2Cicons-editing-styling%2Cicons-interactions%2Cicons-layout%2Cicons-location%2Cicons-media%2Cicons-moderation%2Cicons-movement%2Cicons-wikimedia%2Cindicators%2Ctextures&skin=vector&version=0jag1x4:2218:314
mightThrow@https://en.wikipedia.org/w/load.php?debug=false&lang=en&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=1nv7gwr:49:590
resolve/</process<@https://en.wikipedia.org/w/load.php?debug=false&lang=en&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=1nv7gwr:50:269
undefined

Event Timeline

Stryn created this task.Apr 25 2018, 3:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 25 2018, 3:52 PM
Deskana triaged this task as High priority.Apr 25 2018, 5:07 PM
Deskana edited projects, added VisualEditor (Current work); removed VisualEditor.
Deskana added a subscriber: Deskana.

This might explain why things went wrong in T168886#4120150; it may have been unrelated to the actual centralisation of feedback, and caused by this instead. Oops.

Cirdan added a subscriber: Cirdan.Apr 29 2018, 7:57 AM

Change 429705 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Follow-up Iea7ad832: Fix context in MWPopupTool

https://gerrit.wikimedia.org/r/429705

Esanders claimed this task.Apr 29 2018, 9:10 PM
Esanders moved this task from Incoming to Code review on the VisualEditor (Current work) board.

Change 429705 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Follow-up Iea7ad832: Fix context in MWPopupTool

https://gerrit.wikimedia.org/r/429705

Deskana closed this task as Resolved.Apr 30 2018, 4:01 PM

Maybe another try at the deployment of T168886#4120150 should be attempted.

Vvjjkkii renamed this task from Visual editor's "leave feedback about this software" doesn't open to 08daaaaaaa.Jul 1 2018, 1:13 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Esanders as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii edited subscribers, added: Esanders; removed: gerritbot, Aklapper.
Mainframe98 renamed this task from 08daaaaaaa to Visual editor's "leave feedback about this software" doesn't open.Jul 1 2018, 8:10 AM
Mainframe98 closed this task as Resolved.
Mainframe98 assigned this task to Esanders.
Mainframe98 updated the task description. (Show Details)
Mainframe98 edited subscribers, added: gerritbot, Aklapper; removed: Esanders.