Page MenuHomePhabricator

Set interwiki links for links in the edit summary
Closed, ResolvedPublic5 Story Points

Description

Motivation
Currently, local page links in the edit summary become red links when the move happened. They should still direct to the right location, though.

Example:

Acceptance Criteria

  • The local page links become interwiki links, so they point to the same page that they used to point to before
  • Add the interwiki descriptions before the shown link, e.g. wp:Category:XYZ

Notes

  • if there is a prefix before the file, we will just add ours to the front
  • we would need to parse all summaries to get the urls out, should probably be done with the regular linker. This makes it complicated, though
  • Right now, the wiki text importer does not change links, either.

Event Timeline

Restricted Application added a project: TCB-Team. · View Herald TranscriptMay 14 2018, 10:51 AM
Lea_WMDE triaged this task as Normal priority.May 29 2018, 1:43 PM
Lea_WMDE updated the task description. (Show Details)
Lea_WMDE updated the task description. (Show Details)May 29 2018, 1:46 PM
Lea_WMDE updated the task description. (Show Details)Jun 12 2018, 9:26 AM
Lea_WMDE set the point value for this task to 5.
WMDE-Fisch moved this task from Sprint Backlog to Doing on the WMDE-QWERTY-Sprint-2018-06-19 board.

Change 441547 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[mediawiki/extensions/FileImporter@master] Set interwiki links for links in the edit summary

https://gerrit.wikimedia.org/r/441547

Change 441547 merged by jenkins-bot:
[mediawiki/extensions/FileImporter@master] Set interwiki links for links in the edit summary

https://gerrit.wikimedia.org/r/441547

Vvjjkkii renamed this task from Set interwiki links for links in the edit summary to j0caaaaaaa.Jul 1 2018, 1:10 AM
Vvjjkkii removed WMDE-Fisch as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed the point value for this task.
Vvjjkkii edited subscribers, added: WMDE-Fisch; removed: gerritbot.
Ahecht renamed this task from j0caaaaaaa to Set interwiki links for links in the edit summary.Jul 2 2018, 3:26 AM
Ahecht assigned this task to WMDE-Fisch.
Ahecht lowered the priority of this task from High to Normal.
Ahecht updated the task description. (Show Details)
Ahecht set the point value for this task to 5.
Ahecht edited subscribers, added: GerritBot; removed: WMDE-Fisch.
Ahecht edited subscribers, added: gerritbot; removed: GerritBot.Jul 2 2018, 3:29 AM
Lea_WMDE closed this task as Resolved.Jul 3 2018, 3:22 PM
Lea_WMDE moved this task from Demo to Done on the WMDE-QWERTY-Sprint-2018-06-19 board.

@Lea_WMDE You now closed this ticket as resolved but you also closed T196647 as duplicate of this ticket, it's content however is not fixed yet. Should we reopen it?

@MichaelSchoenitzer_WMDE sorry for the mixup. The ticket you mentioned was just merged into another open ticket (Thanks for that!) and so I think we still have everything on our radar.