Page MenuHomePhabricator

Internal error when viewing a page (EntityLookupException)
Closed, ResolvedPublic

Description

Hello,

Getting the internal error on try viewing at frwiki page https://fr.wikipedia.org/wiki/Cracovie.

Error is :

[WwhSEwpAICMAALKnaggAAABH] 2018-05-25 18:12:37: Erreur fatale de type « Wikibase\DataModel\Services\Lookup\EntityLookupException »

reported at : https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Le_Bistro/25_mai_2018#Problème_technique_du_serveur_?

(sorry for my bad english)

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 25 2018, 6:19 PM
Reedy added a subscriber: Reedy.

Related to the mitigations of T195520?

Reedy added a comment.May 25 2018, 6:46 PM
2018-05-25 18:12:37 [WwhSEwpAICMAALKnaggAAABH] mw1333 frwiki 1.32.0-wmf.4 exception ERROR: [WwhSEwpAICMAALKnaggAAABH] /wiki/Cracovie   Wikibase\DataModel\Services\Lookup\EntityLookupException from line 44 of /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/RevisionBasedEntityLookup.php: The serialization "L1041" is not recognized by the configured id builders {"exception_id":"WwhSEwpAICMAALKnaggAAABH","exception_url":"/wiki/Cracovie","caught_by":"mwe_handler"} 
[Exception Wikibase\DataModel\Services\Lookup\EntityLookupException] (/srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/RevisionBasedEntityLookup.php:44) The serialization "L1041" is not recognized by the configured id builders
  #0 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-services/src/Lookup/RedirectResolvingEntityLookup.php(51): Wikibase\Lib\Store\RevisionBasedEntityLookup->getEntity(Wikibase\DataModel\Entity\ItemId)
  #1 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/LangLinkHandler.php(109): Wikibase\DataModel\Services\Lookup\RedirectResolvingEntityLookup->getEntity(Wikibase\DataModel\Entity\ItemId)
  #2 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/LangLinkHandler.php(331): Wikibase\Client\LangLinkHandler->getEntityLinks(Title)
  #3 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/LangLinkHandler.php(352): Wikibase\Client\LangLinkHandler->getEffectiveRepoLinks(Title, ParserOutput)
  #4 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/Hooks/ParserOutputUpdateHookHandlers.php(97): Wikibase\Client\LangLinkHandler->addLinksFromRepository(Title, ParserOutput)
  #5 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/Hooks/ParserOutputUpdateHookHandlers.php(65): Wikibase\Client\Hooks\ParserOutputUpdateHookHandlers->doContentAlterParserOutput(Title, ParserOutput)
  #6 /srv/mediawiki/php-1.32.0-wmf.4/includes/Hooks.php(177): Wikibase\Client\Hooks\ParserOutputUpdateHookHandlers::onContentAlterParserOutput(WikitextContent, Title, ParserOutput)
  #7 /srv/mediawiki/php-1.32.0-wmf.4/includes/Hooks.php(205): Hooks::callHook(string, array, array, NULL)
  #8 /srv/mediawiki/php-1.32.0-wmf.4/includes/content/AbstractContent.php(520): Hooks::run(string, array)
  #9 /srv/mediawiki/php-1.32.0-wmf.4/includes/poolcounter/PoolWorkArticleView.php(145): AbstractContent->getParserOutput(Title, integer, ParserOptions)
  #10 /srv/mediawiki/php-1.32.0-wmf.4/includes/poolcounter/PoolCounterWork.php(123): PoolWorkArticleView->doWork()
  #11 /srv/mediawiki/php-1.32.0-wmf.4/includes/page/Article.php(604): PoolCounterWork->execute()
  #12 /srv/mediawiki/php-1.32.0-wmf.4/includes/actions/ViewAction.php(68): Article->view()
  #13 /srv/mediawiki/php-1.32.0-wmf.4/includes/MediaWiki.php(500): ViewAction->show()
  #14 /srv/mediawiki/php-1.32.0-wmf.4/includes/MediaWiki.php(294): MediaWiki->performAction(Article, Title)
  #15 /srv/mediawiki/php-1.32.0-wmf.4/includes/MediaWiki.php(861): MediaWiki->performRequest()
  #16 /srv/mediawiki/php-1.32.0-wmf.4/includes/MediaWiki.php(524): MediaWiki->main()
  #17 /srv/mediawiki/php-1.32.0-wmf.4/index.php(42): MediaWiki->run()
  #18 /srv/mediawiki/w/index.php(3): include(string)
  #19 {main}
Caused by: [Exception Wikibase\DataModel\Entity\EntityIdParsingException] (/srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model/src/Entity/DispatchingEntityIdParser.php:60) The serialization "L1041" is not recognized by the configured id builders
  #0 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-services/src/EntityId/PrefixMappingEntityIdParser.php(86): Wikibase\DataModel\Entity\DispatchingEntityIdParser->parse(string)
  #1 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Serialization/RepositorySpecificDataValueDeserializerFactory.php(70): Wikibase\DataModel\Services\EntityId\PrefixMappingEntityIdParser->parse(string)
  #2 /srv/mediawiki/php-1.32.0-wmf.4/vendor/data-values/serialization/src/Deserializers/DataValueDeserializer.php(122): Closure$Wikibase\Lib\Serialization\RepositorySpecificDataValueDeserializerFactory::newDeserializerForRepository(array)
  #3 /srv/mediawiki/php-1.32.0-wmf.4/vendor/data-values/serialization/src/Deserializers/DataValueDeserializer.php(91): DataValues\Deserializers\DataValueDeserializer->getDeserialization(array)
  #4 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/SnakDeserializer.php(118): DataValues\Deserializers\DataValueDeserializer->deserialize(array)
  #5 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/SnakDeserializer.php(108): Wikibase\DataModel\Deserializers\SnakDeserializer->deserializeDataValue(array)
  #6 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/SnakDeserializer.php(90): Wikibase\DataModel\Deserializers\SnakDeserializer->newValueSnak(array)
  #7 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/SnakDeserializer.php(72): Wikibase\DataModel\Deserializers\SnakDeserializer->getDeserialized(array)
  #8 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/SnakListDeserializer.php(60): Wikibase\DataModel\Deserializers\SnakDeserializer->deserialize(array)
  #9 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/SnakListDeserializer.php(41): Wikibase\DataModel\Deserializers\SnakListDeserializer->getDeserialized(array)
  #10 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/StatementDeserializer.php(140): Wikibase\DataModel\Deserializers\SnakListDeserializer->deserialize(array)
  #11 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/StatementDeserializer.php(118): Wikibase\DataModel\Deserializers\StatementDeserializer->setQualifiersFromSerialization(array, Wikibase\DataModel\Statement\Statement)
  #12 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/StatementDeserializer.php(100): Wikibase\DataModel\Deserializers\StatementDeserializer->getDeserialized(array)
  #13 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/StatementListDeserializer.php(60): Wikibase\DataModel\Deserializers\StatementDeserializer->deserialize(array)
  #14 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/StatementListDeserializer.php(41): Wikibase\DataModel\Deserializers\StatementListDeserializer->getDeserialized(array)
  #15 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/ItemDeserializer.php(130): Wikibase\DataModel\Deserializers\StatementListDeserializer->deserialize(array)
  #16 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/ItemDeserializer.php(85): Wikibase\DataModel\Deserializers\ItemDeserializer->setStatementListFromSerialization(array, Wikibase\DataModel\Entity\Item)
  #17 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-serialization/src/Deserializers/ItemDeserializer.php(77): Wikibase\DataModel\Deserializers\ItemDeserializer->getDeserialized(array)
  #18 /srv/mediawiki/php-1.32.0-wmf.4/vendor/serialization/serialization/src/Deserializers/DispatchingDeserializer.php(42): Wikibase\DataModel\Deserializers\ItemDeserializer->deserialize(array)
  #19 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/internal-serialization/src/Deserializers/EntityDeserializer.php(47): Deserializers\DispatchingDeserializer->deserialize(array)
  #20 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/EntityContentDataCodec.php(252): Wikibase\InternalSerialization\Deserializers\EntityDeserializer->deserialize(array)
  #21 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/Sql/WikiPageEntityRevisionLookup.php(163): Wikibase\Lib\Store\EntityContentDataCodec->decodeEntity(string, NULL)
  #22 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/Sql/WikiPageEntityRevisionLookup.php(92): Wikibase\Lib\Store\Sql\WikiPageEntityRevisionLookup->loadEntity(stdClass)
  #23 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/DispatchingEntityRevisionLookup.php(59): Wikibase\Lib\Store\Sql\WikiPageEntityRevisionLookup->getEntityRevision(Wikibase\DataModel\Entity\ItemId, integer, string)
  #24 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/CachingEntityRevisionLookup.php(104): Wikibase\Lib\Store\DispatchingEntityRevisionLookup->getEntityRevision(Wikibase\DataModel\Entity\ItemId, integer, string)
  #25 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/CachingEntityRevisionLookup.php(87): Wikibase\Lib\Store\CachingEntityRevisionLookup->fetchEntityRevision(Wikibase\DataModel\Entity\ItemId, integer, string)
  #26 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/CachingEntityRevisionLookup.php(104): Wikibase\Lib\Store\CachingEntityRevisionLookup->getEntityRevision(Wikibase\DataModel\Entity\ItemId, integer, string)
  #27 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/CachingEntityRevisionLookup.php(87): Wikibase\Lib\Store\CachingEntityRevisionLookup->fetchEntityRevision(Wikibase\DataModel\Entity\ItemId, integer, string)
  #28 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/lib/includes/Store/RevisionBasedEntityLookup.php(39): Wikibase\Lib\Store\CachingEntityRevisionLookup->getEntityRevision(Wikibase\DataModel\Entity\ItemId)
  #29 /srv/mediawiki/php-1.32.0-wmf.4/vendor/wikibase/data-model-services/src/Lookup/RedirectResolvingEntityLookup.php(51): Wikibase\Lib\Store\RevisionBasedEntityLookup->getEntity(Wikibase\DataModel\Entity\ItemId)
  #30 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/LangLinkHandler.php(109): Wikibase\DataModel\Services\Lookup\RedirectResolvingEntityLookup->getEntity(Wikibase\DataModel\Entity\ItemId)
  #31 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/LangLinkHandler.php(331): Wikibase\Client\LangLinkHandler->getEntityLinks(Title)
  #32 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/LangLinkHandler.php(352): Wikibase\Client\LangLinkHandler->getEffectiveRepoLinks(Title, ParserOutput)
  #33 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/Hooks/ParserOutputUpdateHookHandlers.php(97): Wikibase\Client\LangLinkHandler->addLinksFromRepository(Title, ParserOutput)
  #34 /srv/mediawiki/php-1.32.0-wmf.4/extensions/Wikibase/client/includes/Hooks/ParserOutputUpdateHookHandlers.php(65): Wikibase\Client\Hooks\ParserOutputUpdateHookHandlers->doContentAlterParserOutput(Title, ParserOutput)
  #35 /srv/mediawiki/php-1.32.0-wmf.4/includes/Hooks.php(177): Wikibase\Client\Hooks\ParserOutputUpdateHookHandlers::onContentAlterParserOutput(WikitextContent, Title, ParserOutput)
  #36 /srv/mediawiki/php-1.32.0-wmf.4/includes/Hooks.php(205): Hooks::callHook(string, array, array, NULL)
  #37 /srv/mediawiki/php-1.32.0-wmf.4/includes/content/AbstractContent.php(520): Hooks::run(string, array)
  #38 /srv/mediawiki/php-1.32.0-wmf.4/includes/poolcounter/PoolWorkArticleView.php(145): AbstractContent->getParserOutput(Title, integer, ParserOptions)
  #39 /srv/mediawiki/php-1.32.0-wmf.4/includes/poolcounter/PoolCounterWork.php(123): PoolWorkArticleView->doWork()
  #40 /srv/mediawiki/php-1.32.0-wmf.4/includes/page/Article.php(604): PoolCounterWork->execute()
  #41 /srv/mediawiki/php-1.32.0-wmf.4/includes/actions/ViewAction.php(68): Article->view()
  #42 /srv/mediawiki/php-1.32.0-wmf.4/includes/MediaWiki.php(500): ViewAction->show()
  #43 /srv/mediawiki/php-1.32.0-wmf.4/includes/MediaWiki.php(294): MediaWiki->performAction(Article, Title)
  #44 /srv/mediawiki/php-1.32.0-wmf.4/includes/MediaWiki.php(861): MediaWiki->performRequest()
  #45 /srv/mediawiki/php-1.32.0-wmf.4/includes/MediaWiki.php(524): MediaWiki->main()
  #46 /srv/mediawiki/php-1.32.0-wmf.4/index.php(42): MediaWiki->run()
  #47 /srv/mediawiki/w/index.php(3): include(string)
  #48 {main}

Occurrence in logstash:

Addshore claimed this task.May 25 2018, 7:00 PM
Addshore added a project: Lexicographical data.

Related to the mitigations of T195520?

Looks like a no.

Looks like this is related to the WikibaseLexeme deployment that happened earlier in the week.
Lexeme being used on items seem to use this.

Restricted Application added a project: User-Addshore. · View Herald TranscriptMay 25 2018, 7:00 PM

The page this ticket was opened for https://fr.wikipedia.org/wiki/Cracovie now loads correctly thanks to https://www.wikidata.org/w/index.php?title=Q31487&diff=684995568&oldid=684995354

I'm going to try to add an AbuseFilter on Wikidata to stop any more occurrences over the weekend..

This can can now confirm that there are no more occurrences :) The below query can help us easily check.

select * from pagelinks where pl_from_namespace = 0 and pl_namespace = 146;

I created https://www.wikidata.org/wiki/Special:AbuseFilter/102 for the weekend and confirmed it is working @ https://www.wikidata.org/wiki/Special:AbuseLog/4537028

If this causes any problems the filter could also have a check added to it to look for the word "lexeme" in the edit_diff, but should be fine for now.

Addshore renamed this task from Internal error when viewing an page to Internal error when viewing a page (EntityLookupException).May 25 2018, 7:43 PM
Lydia_Pintscher closed this task as Resolved.May 27 2018, 4:15 PM

Closing this as the problem has been solved and measures have been put in place to prevent adding new links to Lexemes. And we have the ticket for fixing it properly in T195615.

Vvjjkkii renamed this task from Internal error when viewing a page (EntityLookupException) to o9baaaaaaa.Jul 1 2018, 1:07 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Addshore as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from o9baaaaaaa to Internal error when viewing a page (EntityLookupException).Jul 2 2018, 3:44 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Addshore.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.

Change 443887 had a related patch set uploaded (by Eileen; owner: Eileen):
[wikimedia/fundraising/crm@master] Enotice fix - much as I would like it I can't give all fields titles in the metadata.

https://gerrit.wikimedia.org/r/443887

Change 443887 merged by jenkins-bot:
[wikimedia/fundraising/crm@master] Enotice fix - much as I would like it I can't give all fields titles in the metadata.

https://gerrit.wikimedia.org/r/443887