Page MenuHomePhabricator

Bug: When a Talk Page is Refreshed After Saving Edits, it Re-Enters Edit-Mode
Closed, DeclinedPublic

Description

Steps:

  1. occurs for me on firefox, chrome, and IE browsers (so far)
  2. visit https://www.mediawiki.org/wiki/Extension_talk:TableEdit
  3. log in if not already logged in
  4. enter edit mode on an existing topic
  5. click in the empty line at the end of the topic
  6. hit backspace to remove the empty line
  7. save your changes by clicking "Publish Changes" button.
  8. click publish again, in the summary window, without adding a comment.
  9. page is now in read-mode. notice the tabs-- you're on the "Read" tab.
  10. check the address bar-- "action=edit" is STILL unexpectedly in the address bar.
  11. do a browser-refresh (CTRL-r on Chrome)
  12. page will unexpectedly re-enter edit-mode.

also occurs for me on https://www.mediawiki.org/wiki/API_talk:Import
plz test.

(Note, if "Stalled" means the OP has not provided complete information, this task isn't stalled.)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Hi, could you clarify on which exact page (URL) this happens? https://www.wikimedia.org/ does not offer talk pages, as far as I know. Thanks!

Johnywhy updated the task description. (Show Details)May 28 2018, 12:50 PM
Johnywhy renamed this task from Bug: When a Talk Page is Refreshed, it Enters Edit-Mode to Bug: When a Talk Page is Refreshed After Saving Edits, it Re-Enters Edit-Mode.May 28 2018, 12:53 PM
Johnywhy updated the task description. (Show Details)
Johnywhy updated the task description. (Show Details)
Johnywhy updated the task description. (Show Details)May 28 2018, 12:55 PM

That page doesn't use StructuredDiscussions so I don't understand that bug.

Johnywhy added a comment.EditedMay 28 2018, 1:24 PM

That page doesn't use StructuredDiscussions so I don't understand that bug.

then this bug is tagged incorrectly. Maybe it should be tagged to MediaWiki rather than StructuredDiscussions?

But surely you can see that it is, in fact, a bug, can't you?

This comment was removed by Johnywhy.
Aklapper changed the task status from Open to Stalled.May 28 2018, 1:32 PM
  1. Go to https://www.mediawiki.org/wiki/User_talk:AKlapper_(WMF)
  2. Click "Add Topic" tab in right top bar
  3. End up in WikiEditor 2010 editor
  4. Enter subject and content
  5. Click blue "Publish Changes" button
  6. Right top bar highlights "Read" tab
  7. URL address bar in Firefox 60 shows https://www.mediawiki.org/wiki/User_talk:AKlapper_(WMF)#Testing_phab:T195761 and includes no action=edit

Cannot reproduce.

Johnywhy updated the task description. (Show Details)May 28 2018, 3:12 PM
Johnywhy updated the task description. (Show Details)
  1. Go to https://www.mediawiki.org/w/index.php?title=User_talk:AKlapper_(WMF)&action=edit&section=59 with WikiEditor 2010 editor
  2. Add another line
  3. Click blue "Publish Changes" button
  4. Right top bar highlights "Read" tab
  5. URL address bar in Chromium 65 shows https://www.mediawiki.org/wiki/User_talk:AKlapper_(WMF)#Testing_phab:T195761 and includes no action=edit

Still cannot reproduce.

I do not expect any bug in MediaWiki software but a misbehavior in the local web browser (and/or its extensions/add-ons), as the browser's location bar content (action=edit) does not fit what's actually displayed (Read mode).

@Aklapper Your test is invalid. You did not duplicate my test conditions.

I reproduced this on Chrome browser with all extensions disabled.

@Johnywhy: My last comment says "Chromium 65", not Firefox. This task might be a question for a MediaWiki or Chrome/Chromium support forum instead.

It would be more helpful if you actually explained what's incorrect/missing instead. (If it's about Chromium instead of Chrome, I am not going to install Chrome.)

Johnywhy added a comment.EditedMay 29 2018, 9:21 AM

i have explained what's incorrect. What's missing from my description?

if you're not going to duplicate my test conditions, then you cannot claim that you cannot duplicate the bug.

Johnywhy changed the task status from Stalled to Open.May 29 2018, 9:21 AM
Johnywhy updated the task description. (Show Details)
Aklapper changed the task status from Open to Stalled.May 29 2018, 9:23 AM

I made a null edit on https://www.mediawiki.org/wiki/Extension_talk:TableEdit (as I won't add nonsense to that page) and I could not reproduce the problem either.

This task is in stalled status until conditions are provided that allow someone else to reproduce the problem.

I made an edit to the page using the steps provided in the task description, and could not reproduce the problem.

I made an edit to the page using the steps provided in the task description, and could not reproduce the problem.

on chrome browser?

on chrome browser?

[…] using the steps provided in the task description […]

The answer to your question is in the comment I wrote. Yes.

Johnywhy added a comment.EditedMay 29 2018, 9:32 AM

on chrome browser?

! In T195761#4238151, @Deskana wrote:

[…] using the steps provided in the task description […]

The answer to your question is in the comment I wrote. Yes.

Don't take offense. @Aklapper claimed he could not duplicate the bug, after testing in a different browser (Firefox and Chromium) on a different page.

Johnywhy updated the task description. (Show Details)May 29 2018, 9:38 AM

Bug found on IE too.
I've added more detail to my test steps.
Please try again with my updated steps.

Johnywhy updated the task description. (Show Details)May 29 2018, 9:41 AM
Johnywhy updated the task description. (Show Details)
Johnywhy updated the task description. (Show Details)
Johnywhy updated the task description. (Show Details)
Johnywhy updated the task description. (Show Details)May 29 2018, 9:44 AM
Johnywhy updated the task description. (Show Details)
Johnywhy added a comment.EditedMay 29 2018, 1:11 PM

i have duplicated this problem on Firefox, new clean Firefox downloaded today. On windows 8.x

Johnywhy updated the task description. (Show Details)May 29 2018, 1:13 PM
Johnywhy changed the task status from Stalled to Open.May 30 2018, 8:00 AM
Johnywhy updated the task description. (Show Details)

T195914 (coming from https://en.wikipedia.org/wiki/Wikipedia:Help_desk?#Prevent_edit_source_auto_launch ) might be the same problem: "the User TalkPage automatically launches in edit source mode and not the static (read) mode I am used to."

@Aklapper have you duplicated the problem?

@Deskana here's a screen capture of this bug on Firefox. I'm getting identical behavior on Chrome. Can you possibly share a capture of your test, so i can see what we're doing differently?

Johnywhy added a comment.EditedJun 18 2018, 3:36 PM

May be related.
Page title says "Edit", even though url doesn't contain action=edit

Vvjjkkii renamed this task from Bug: When a Talk Page is Refreshed After Saving Edits, it Re-Enters Edit-Mode to i5baaaaaaa.Jul 1 2018, 1:07 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from i5baaaaaaa to Bug: When a Talk Page is Refreshed After Saving Edits, it Re-Enters Edit-Mode.Jul 2 2018, 3:34 PM
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.
TheDJ added a subscriber: TheDJ.

The video makes it clear that the user is WE2017
Sort of critical information. Could also have been deduced from the description's: "publish again, in the summary window"

But it seems the behavior has since changed. Cannot reproduce any longer (5 months later, so.....)
@Johnywhy do you still see this problem ?

Restricted Application added a project: VisualEditor. · View Herald TranscriptNov 16 2018, 9:14 PM

Will report back next time I try.

JTannerWMF moved this task from To Triage to Blocked on the VisualEditor board.Nov 20 2018, 3:56 PM
JTannerWMF moved this task from Blocked to Q4 on the VisualEditor board.Dec 12 2018, 3:54 PM
JTannerWMF changed the task status from Open to Stalled.Jan 16 2019, 7:22 PM
Aklapper closed this task as Declined.Sat, Sep 14, 9:43 PM

Unfortunately closing this report as no further information has been provided.

@Johnywhy: If this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!