Page MenuHomePhabricator

Creating new usergroup "event participant" for zh.wikipedia
Closed, ResolvedPublic

Description

Please add a new usergroup: eventparticipants
This usergroup should have the following rights:
autoconfirmed, upload, reupload, captcha

This group can be added by both sysop and accountcreator and can be removed by both groups.

This new user group is from the following archived discussion:
https://zh.wikipedia.org/wiki/Wikipedia_talk:%E5%A4%A7%E9%87%8F%E5%B8%B3%E8%99%9F%E5%BB%BA%E7%AB%8B%E8%80%85#%E4%BF%AE%E8%A8%82Wikipedia:%E5%A4%A7%E9%87%8F%E5%B8%B3%E8%99%9F%E5%BB%BA%E7%AB%8B%E8%80%85%E6%96%B9%E9%87%9D%EF%BC%8C%E8%B3%A6%E4%BA%88%E9%A1%8D%E5%A4%96%E6%AC%8A%E9%99%90


Please note that this is a backlog request.

Event Timeline

Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptJun 26 2018, 6:05 AM
1233thehongkonger updated the task description. (Show Details)
Wong128hk renamed this task from New usergroup for zhwp to Creating new usergroup "event participant" for zh.wikipedia.Jun 26 2018, 8:55 AM
Wong128hk removed a subscriber: Chinese-Sites.
Wong128hk updated the task description. (Show Details)Jun 26 2018, 9:09 AM

I suggest allowing accountcreators granting and/or removing confirmed user group instead. This user group contains all rights wanted. The result would be almost the same, confirmed users can for example move pages as well, but I really don't think such right would be dangerous for people from courses.

Urbanecm claimed this task.Jun 27 2018, 4:59 AM
Urbanecm triaged this task as Normal priority.
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptJun 27 2018, 4:59 AM

Well, consensus showed that we do not want to do so. At the same time, @Urbanecm , I had proposed that but our result is: We should give only the required necessary rights.

There is another problem about our own filters.

IMHO the (auto)confirmed thing is just to stop people coming potentionally in bad faith to doing potentionally dangerous things (such as page move). I really do not think it is _that big_ problem to allow them to move page as well. I know that we should not grant not necessary rights, but this isn't the case, because after a few of days, they'll receive move right automatically.

I know that you have consensus for this, but consensus a) can change b) is not everything. There also is a need for somebody confortable with processing the change, I'm not sure there is a need for this change.

What filters can be problem? Remember, that all such filters will be bypassed after 4 days.

after 4 days.

On zhwiki, automatically confirm a user requires this user has been registered for 7 days and has 50 edits. The community has a high demand for it.

Oh, that change a lot of things. 50 edits is a lot and it takes some time to get such number of edits. Then, I'm convinced and I'm going to proceed this request.

Change 442286 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Create group eventparticipant on zhwiki

https://gerrit.wikimedia.org/r/442286

Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.Jun 27 2018, 12:18 PM
Urbanecm moved this task from Backlog to To deploy on the Wikimedia-Site-requests board.

Change 442287 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/WikimediaMessages@master] Introduce eventparticipant user group

https://gerrit.wikimedia.org/r/442287

Change 442287 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Declare eventparticipant user group to WikimediaMessages

https://gerrit.wikimedia.org/r/442287

Vvjjkkii renamed this task from Creating new usergroup "event participant" for zh.wikipedia to oaaaaaaaaa.Jul 1 2018, 1:02 AM
Vvjjkkii removed Urbanecm as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptJul 1 2018, 1:02 AM
Wong128hk renamed this task from oaaaaaaaaa to Creating new usergroup "event participant" for zh.wikipedia.Jul 1 2018, 2:19 AM
Wong128hk assigned this task to Urbanecm.
Wong128hk lowered the priority of this task from High to Normal.
Wong128hk updated the task description. (Show Details)
Wong128hk edited subscribers, added: gerritbot, Aklapper; removed: Dereckson.

Change 442286 merged by jenkins-bot:
[operations/mediawiki-config@master] Create group eventparticipant on zhwiki

https://gerrit.wikimedia.org/r/442286

Mentioned in SAL (#wikimedia-operations) [2018-07-09T11:31:27Z] <zfilipin@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:442286|Create group eventparticipant on zhwiki (T198167)]] (duration: 00m 51s)

Urbanecm closed this task as Resolved.Jul 9 2018, 11:57 AM

Deployed. Should it be broken, reopen&comment.

Not broken. Thanks for claiming this task @Urbanecm

You're welcome. Glad I could help.