Page MenuHomePhabricator

[Regression pre-wmf.10] Media dialog in VE is not opening, throwing error "jQuery.Deferred exception: this.categoriesWidget.setItemsFromData is not a function. TypeError: this.categoriesWidget.setItemsFromData is not a function"
Closed, ResolvedPublic

Description

Media search dialog in VE is not opening

The following error appears in the console:

load.php?debug=false&lang=en&modules=jquery%2Cmediawiki|mediawiki.base|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1qaigzl:52 jQuery.Deferred exception: this.categoriesWidget.setItemsFromData is not a function TypeError: this.categoriesWidget.setItemsFromData is not a function
    at mw.ForeignStructuredUpload.BookletLayout.clear (<anonymous>:1289:135)
    at mw.ForeignStructuredUpload.BookletLayout.mw.Upload.BookletLayout.initialize (<anonymous>:1242:788)
    at mw.ForeignStructuredUpload.BookletLayout.initialize (<anonymous>:1280:2353)
    at VeUiMWMediaDialog.<anonymous> (<anonymous>:1329:265)
    at <anonymous>:119:113
    at mightThrow (https://en.wikipedia.beta.wmflabs.org/w/load.php?debug=false&lang=en&modules=jquery%2Cmediawiki%7Cmediawiki.base%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=1qaigzl:49:598)
    at process (https://en.wikipedia.beta.wmflabs.org/w/load.php?debug=false&lang=en&modules=jquery%2Cmediawiki%7Cmediawiki.base%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=1qaigzl:50:269) undefined

Event Timeline

Ryasmeen created this task.Jun 27 2018, 9:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 27 2018, 9:57 PM
Ryasmeen updated the task description. (Show Details)Jun 27 2018, 9:58 PM

FYI, this is happening for Find and Replace dialog as well.

Deskana triaged this task as High priority.Jun 28 2018, 12:53 PM

Change 442784 had a related patch set uploaded (by Bartosz Dziewoński; owner: Prtksxna):
[mediawiki/core@master] ForeignStructuredUpload: Stop using methods from CapsuleMultiselectWidget

https://gerrit.wikimedia.org/r/442784

FYI, this is happening for Find and Replace dialog as well.

I can't reproduce this problem.

Change 442784 merged by Krinkle:
[mediawiki/core@master] ForeignStructuredUpload: Stop using methods from CapsuleMultiselectWidget

https://gerrit.wikimedia.org/r/442784

Prtksxna added a comment.EditedJun 29 2018, 1:53 AM

Errr, sorry, never mind my comment :/

Tested locally, works for me now.
(yep, without the patch the media dialog (search or upload) wasn't opening at all)

Tested on Beta cluster, fixed now.

Deskana closed this task as Resolved.Jul 2 2018, 11:05 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 2 2018, 11:05 AM