Page MenuHomePhabricator

ContentTranslation substitutes some templates in the references
Closed, InvalidPublic

Description

Reference is poorly adapted when translating "Tradícia_(zvyky)" for from Slovak (sk) to Czech (cs). The result shows that the reference has plain text content extracted from a warning message of the filled template, in addition to the filled template:

More details

Original in Slovak (version used):

...medzigeneračného prenosu.<ref>{{Harvbz|Shils|Rok=1983, ©1981|St=15-16}}</ref>

Translation to Czech (view version translated):

...mezigeneračního přenosu.<ref>{{Harvnb|Shils}}Je zde použita šablona <code>{&#x7B;[[Šablona:Harvnb|Harvnb]]<nowiki>}}</nowiki></code> označená jako k „pouze dočasnému použití“. [[Kategorie:Údržba:Články s dočasně použitou šablonou]]</ref>

Two aspects to consider:

  • Warning text leaking as content. 'Je zde použita šablona Harvnb označená jako k „pouze dočasnému použití“' means 'Harvnb template is marked as "temporary use only"', which is a warning shown on the Czech version of the Harvnb template that leaks as content. Avoiding this is the main scope of the task.
  • Using the preferred template. The equivalent of sk:Harvbz is cs:Harvnb according to Wikidata. In this particular case, the Harvnb templated is discouraged in Czech Wikipedia (which is communicated in a template at the top of the template description page) but overriding the Wikidata equivalent template for some other community preference is a separate issue.

The scope of the current task is to adapt the template to the corresponding one according to Wikidata without anything leaking as content outside the template. Selecting a different template is not in the scope of the current task.

We want to focus our efforts to verify this for version 2 of Content Translation


Additional information by the original reporter: "This issue is really old, I remember I fixed broken articles like this 3 or 4 years ago."

Event Timeline

Dvorapa created this task.Jul 5 2018, 8:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 5 2018, 8:21 PM
Dvorapa updated the task description. (Show Details)Jul 5 2018, 8:22 PM

Currently we are working on a new version of Content Translation which provides a more solid editing surface and it is expected to solve this kind of issues. Can you try to reproduce the issue with version 2, and report if it is still a problem with the new version?
Thanks!

(I only time to time fix the wrong articles, I'm not aware of how to reproduce it)

Pginer-WMF closed this task as Declined.Jul 9 2018, 3:54 PM
Pginer-WMF added a subscriber: Amire80.

We have inspected the diffs, and could not identify an issue that fits in the description of the title. Feel free to reopen if a similar issue is found with more detailed information. @Amire80 will try to find similar reports with more detail.

Dvorapa reopened this task as Open.EditedJul 9 2018, 5:57 PM

See this part in the example:

<ref>{{Harvnb|Shils}}Je zde použita šablona <code>{&#x7B;[[Šablona:Harvnb|Harvnb]]<nowiki>}}</nowiki></code> označená jako k „pouze dočasnému použití“.
[[Kategorie:Údržba:Články s dočasně použitou šablonou]]</ref>

There is a part of the content of the local Harvnb template substituted by ContentTranslation. Weird is the fact that only the part of it is substituted, not the whole template. Only the part, which is inside display:hidden span, therefore it is now unexpectedly visible and included twice (once hidden in the template and once visible in the unexpected substitution)

OK, now I understand this.

The reason is that this template probably displays messages that suggest self-correction. For example, some templates in the English Wikipedia show an error message on the rendered page that say that some parameters are missing. Is this something like that?

Parsoid parses them at the wrong time, and Content Translation doesn't know that they aren't supposed to be part of the published article.

OK, now I understand this.
The reason is that this template probably displays messages that suggest self-correction. For example, some templates in the English Wikipedia show an error message on the rendered page that say that some parameters are missing. Is this something like that?
Parsoid parses them at the wrong time, and Content Translation doesn't know that they aren't supposed to be part of the published article.

The message just says in <span style="diplsay:hidden"> that the Harvnb was ported from enwiki only to make article translation easier and should be changed to one of the standard citation templates ASAP. I'm not sure what do you mean by that parsing stuff, but ContentTranslation should definitely not partially subst: templates when they are not meant to be substituted (for those we have got a category https://cs.wikipedia.org/wiki/Kategorie:%C5%A0ablony:Substovan%C3%A9).

Pginer-WMF updated the task description. (Show Details)Jul 17 2018, 10:58 AM
Restricted Application added a subscriber: jeblad. · View Herald TranscriptJul 17 2018, 10:58 AM

Ok, I rewrote the description trying to provide examples and details on which is the actual issue. Thanks for the additional information @Dvorapa and @Amire80. Since I'm not familiar with Czech and Slovak I may have missed something, but feel free to add further clarifications.

Pginer-WMF triaged this task as Normal priority.Jul 17 2018, 11:00 AM
Pginer-WMF moved this task from Check & Move to CX2 on the ContentTranslation board.
Dvorapa updated the task description. (Show Details)Jul 31 2018, 12:37 PM
Restricted Application added a subscriber: Urbanecm. · View Herald TranscriptJan 23 2019, 1:20 PM

A possibly related issue was mentioned in this comment when translating Bloons Tower Defense from English to Russian . Apparently the adaptation of a template resulted in a "templatestyles" attribute being added as part of the content, which triggered an abuse filter and prevented publication. Further investigation may be needed.

I checked the translation of Tradícia_(zvyky)" for from Slovak (sk) to Czech (cs) in CX2. The published article does not have leaked content. The Harvbz template in source langauge does not have a corresponding template in target language, hence it was just copied and just the missing template issue came in published article:

@Dvorapa, We need some help in understanding the issue

https://cs.wikipedia.org/w/index.php?title=Tyramin&action=history
It seems multiple templates partially or fully substituted, including templatestyles!

https://cs.wikipedia.org/w/index.php?title=Tyramin&oldid=16886705 is the version published by the CX.(version 2). Can you help us to locate which template was published with warning content in it? If not, which issue you see with that published article? Can you give a specific template example from that article? (Since I don't know cs or sk languages, it is difficult for me to identify the wrong content)

Pginer-WMF updated the task description. (Show Details)Mar 7 2019, 12:08 PM

I checked the translation of Tradícia_(zvyky)" for from Slovak (sk) to Czech (cs) in CX2. The published article does not have leaked content. The Harvbz template in source langauge does not have a corresponding template in target language, hence it was just copied and just the missing template issue came in published article:

This seems to be wrong - According to Wikidata ( https://www.wikidata.org/wiki/Q6242419#sitelinks-wikipedia ) the equivalent of sk:Harvbz is cs:Harvnb. Source language is Slovak (sk) and target language is Czech (cs). Will check

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMar 29 2019, 9:15 PM

This seems to be wrong - According to Wikidata ( https://www.wikidata.org/wiki/Q6242419#sitelinks-wikipedia ) the equivalent of sk:Harvbz is cs:Harvnb. Source language is Slovak (sk) and target language is Czech (cs). Will check

T217878: CX2: Templates are not adapted after source page inpect mode integration had fixed this.

Regarding the issue of error message leaked in to the published article, I am not able to reproduce with the latest version of CX

Published content by translatingTradícia (zvyky) from sk to cs looks as follows:

@Dvorapa Do you see any issue here? Can you please check if the issue happens now a days and if so provide an example?

The "Harvnb" template itself has been changed and does not contain that leaked part anymore. The same wikitext can be found in templates Coord and Col-begin currently. Anyway, I checked for the leaked wikitext in articles and it seems it does not leak anymore. At least not in the way described here.

Pginer-WMF closed this task as Invalid.Jul 1 2019, 11:45 AM

The "Harvnb" template itself has been changed and does not contain that leaked part anymore. The same wikitext can be found in templates Coord and Col-begin currently. Anyway, I checked for the leaked wikitext in articles and it seems it does not leak anymore. At least not in the way described here.

Reference and template adaptation support has been improved recently, making this issue no longer valid as described according to the comment. If you find other problematic cases, feel free to report. Thanks!

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptJul 1 2019, 11:45 AM