Page MenuHomePhabricator

Js error "Cannot read property 'stack' of undefined" from cxserver
Closed, ResolvedPublic

Description

While translating en:Tennis_scoring_system. Second paragraph of "Scoring a tiebreak game" section gives this error.

The HTML snippet to reproduce the issue:


<section id="cxTargetSection38" data-mw-cx-source="undefined">
<p id="mwmw">

<span data-segmentid="197" class="cx-segment">The server begins his or her service from the
<a href="./Deuce_court" rel="mw:WikiLink" data-linkid="198" class="cx-link" id="mwnA" title="Deuce court">deuce court</a> and serves one point. </span>



<span data-segmentid="201" class="cx-segment">The first of each two-point sequence starts from the server's <a href="./Advantage_court" rel="mw:WikiLink" data-linkid="202" class="cx-link" id="mwnQ" title="Advantage court">advantage court</a>. </span>

</p></section>

The error is from lib/routes/v2.js

res.status( 500 ).end( error.stack );

Event Timeline

santhosh created this task.Jul 18 2018, 9:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 18 2018, 9:41 AM

From the investigation the issue was because of these two links in HTML sample points to same article in English wikipedia. They are redirects. A bug in the API request batching causes a wrng rejection of a Promise in pending state.

Change 446561 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] BatchedAPIRequest: Fix the redirect handling

https://gerrit.wikimedia.org/r/446561

Change 446561 merged by jenkins-bot:
[mediawiki/services/cxserver@master] BatchedAPIRequest: Fix the redirect handling

https://gerrit.wikimedia.org/r/446561

Petar.petkovic moved this task from Backlog to Other on the CX-cxserver board.
Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-07-19T08:00:27Z] <kartik@deploy1001> Started deploy [cxserver/deploy@fe0d521]: Update cxserver to 92e3d2e (T199380, T199885)

Mentioned in SAL (#wikimedia-operations) [2018-07-19T08:04:25Z] <kartik@deploy1001> Finished deploy [cxserver/deploy@fe0d521]: Update cxserver to 92e3d2e (T199380, T199885) (duration: 03m 58s)

Petar.petkovic triaged this task as Normal priority.Jul 19 2018, 10:30 PM
Petar.petkovic closed this task as Resolved.Jul 19 2018, 10:38 PM