MediaWiki core test failure: The table 'archive' is full
Closed, ResolvedPublic

Description

After running for three hours(!), setup-docker-quibble-mw-and-npm fails with

18:24:07 Creating tables
18:24:07 
18:24:07 Fatal error: Uncaught exception 'Wikimedia\Rdbms\DBQueryError' with message 'A database query error has occurred. Did you forget to run your application's database schema updater after upgrading? 
18:24:07 Query: CREATE INDEX name_title_timestamp ON `archive` (ar_namespace,ar_title,ar_timestamp)
18:24:07 
18:24:07 Function: Wikimedia\Rdbms\Database::sourceFile( /workspace/src/maintenance/tables.sql )
18:24:07 Error: 1114 The table 'archive' is full (/tmp/quibble-mysql-bv0fbcg3/socket)
18:24:07 ' in /workspace/src/includes/libs/rdbms/database/Database.php:1443
18:24:07 Stack trace:
18:24:07 #0 /workspace/src/includes/libs/rdbms/database/Database.php(1413): Wikimedia\Rdbms\Database->makeQueryException()
18:24:07 #1 /workspace/src/includes/libs/rdbms/database/Database.php(1186): Wikimedia\Rdbms\Database->reportQueryError()
18:24:07 #2 /workspace/src/includes/libs/rdbms/database/Database.php(4271): Wikimedia\Rdbms\Database->query()
18:24:07 #3 /workspace/src/includes/libs/rdbms/database/Database.php(4206): Wikimedia\Rdbms\Database->sourceStream()
18:24:07 #4 /workspace/src/includes/installer/DatabaseInstaller.php(226): Wikimedia\Rdbms\Database->sourceFile()
18:24:07 #5 /workspace/src/includes/installer/DatabaseInstaller.php(248): DatabaseInstaller->stepApplySourceFile()
18:24:07 #6 /workspace/src/includes/installer/Installer.php(1552): DatabaseInstaller->createTables()
18:24:07 #7 /workspace/src/includes/installer/CliInstaller.php(138): Installer->performInstallation()
18:24:07 #8 /workspace/src/maintenance/install.php(125): CliInstaller->execute()
18:24:07 #9 /workspace/src/maintenance/doMaintenance.php(94): CommandLineInstaller->execute()
18:24:07 #10 /workspace/src/maintenance/install.php(175): include()
18:24:07 #11 {main}
18:24:07 [d18c639c8a41fecd982dd324] [no req]   Wikimedia\Rdbms\DBQueryError from line 1443 of /workspace/src/includes/libs/rdbms/database/Database.php: A database query error has occurred. Did you forget to run your application's database schema updater after upgrading? 
18:24:07 Query: CREATE INDEX name_title_timestamp ON `archive` (ar_namespace,ar_title,ar_timestamp)
18:24:07 
18:24:07 Function: Wikimedia\Rdbms\Database::sourceFile( /workspace/src/maintenance/tables.sql )
18:24:07 Error: 1114 The table 'archive' is full (/tmp/quibble-mysql-bv0fbcg3/socket)
Tgr created this task.Aug 2 2018, 6:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 2 2018, 6:58 PM
Legoktm added a subscriber: Legoktm.Aug 2 2018, 7:00 PM

Disk filled up on 1004. I put the node offline and am cleaning it up...

The excessive delays were caused by timeout failures, https://gerrit.wikimedia.org/r/450076 will relieve most of them I think.

Mentioned in SAL (#wikimedia-releng) [2018-08-02T19:01:08Z] <legoktm> removed all docker images from integration-slave-docker-1004 to free up root partition, cleaned up all workspaces while I was at it (T201077)

Legoktm closed this task as Resolved.Aug 2 2018, 8:05 PM
Legoktm claimed this task.

Should be fixed now. Please re-open/ping me if you see it again.