Page MenuHomePhabricator

AfC: Issues with reloading the page
Closed, ResolvedPublic

Description

(1) Stats reflect the total count of pages disregarding filter selection set.

  1. On Special:NewPagesFeed AfC select some filters and see some results or no results.
  2. Refresh the page - the stats will show the total number of pages in the feed not the actual number of results.

(2) 'All' selection is not sticky when the page is reloaded.

  1. On Special:NewPagesFeed AfC select some option for the State filter, click 'Set filters'.
  2. Select 'All' for the State filter, click 'Set filters' - 'All' will be shown.
  3. Re-load the page - the selection 'All' will be gone, the previously selected State filter option will be displayed.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2018, 11:48 PM
Etonkovidova renamed this task from AfC: Stats reflect the total count of pages disregarding filter selection set to AfC: Issues with reloading the page .Sep 18 2018, 12:08 AM
Etonkovidova updated the task description. (Show Details)
SBisson claimed this task.Sep 18 2018, 12:47 PM
SBisson moved this task from Incoming to In Progress on the Growth-Team (Current Sprint) board.

Change 461149 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/PageTriage@master] Correctly sync the form when afc_state === 'all'

https://gerrit.wikimedia.org/r/461149

Change 461150 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/PageTriage@master] Use same api params for list and stats on page load

https://gerrit.wikimedia.org/r/461150

Change 461149 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Correctly sync the form when afc_state === 'all'

https://gerrit.wikimedia.org/r/461149

Change 461424 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.22] Correctly sync the form when afc_state === 'all'

https://gerrit.wikimedia.org/r/461424

Change 461150 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Use same api params for list and stats on page load

https://gerrit.wikimedia.org/r/461150

Checked the fix in betalabs - the issue is not present anymore.

Change 461648 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.22] Use same api params for list and stats on page load

https://gerrit.wikimedia.org/r/461648

Change 461424 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.22] Correctly sync the form when afc_state === 'all'

https://gerrit.wikimedia.org/r/461424

Change 461648 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.22] Use same api params for list and stats on page load

https://gerrit.wikimedia.org/r/461648

Mentioned in SAL (#wikimedia-operations) [2018-09-20T18:31:46Z] <thcipriani@deploy1001> Synchronized php-1.32.0-wmf.22/extensions/PageTriage/modules: SWAT: [[gerrit:461424|Correctly sync the form when afc_state === "all"]] T204629 [[gerrit:461648|Use same api params for list and stats on page load]] T204629 (duration: 00m 54s)

Mentioned in SAL (#wikimedia-operations) [2018-09-20T18:31:46Z] <thcipriani@deploy1001> Synchronized php-1.32.0-wmf.22/extensions/PageTriage/modules: SWAT: [[gerrit:461424|Correctly sync the form when afc_state === "all"]] T204629 [[gerrit:461648|Use same api params for list and stats on page load]] T204629 (duration: 00m 54s)

Etonkovidova updated the task description. (Show Details)Sep 20 2018, 6:55 PM
Etonkovidova closed this task as Resolved.Sep 20 2018, 8:56 PM