Page MenuHomePhabricator

[betalabs] NPP: 'Potential issues' do not display 'None' and 'Copyvio' filters
Closed, ResolvedPublic

Description

Note:enwiki( wmf.23) - https://en.wikipedia.org/wiki/Special:NewPagesFeed?ores=1&copyvio=1 - displays all 'Potential issues' filter options correctly.

In betalabs two options are missing for NPP pages:

If this is some sort experimentation with a proposed feature flag, then it's ok. However, AfC filters do have 'Copyvio' option and still show the result for 'copyvio' filter but without 'copyvio' indication:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 1 2018, 7:21 PM
Etonkovidova updated the task description. (Show Details)Oct 2 2018, 12:05 AM
SBisson closed this task as Invalid.Oct 2 2018, 12:31 AM

This is by design and it behaves as expected for me

SBisson reopened this task as Open.Oct 2 2018, 4:52 PM
SBisson claimed this task.

It turns out the copyvio feature flag was not quite correct.

Change 463991 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/PageTriage@master] Hide copyvio, none afc filter options behind flag

https://gerrit.wikimedia.org/r/463991

Change 463991 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Hide copyvio, none afc filter options behind flag

https://gerrit.wikimedia.org/r/463991

Change 464021 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.24] Hide copyvio, none afc filter options behind flag

https://gerrit.wikimedia.org/r/464021

Etonkovidova closed this task as Resolved.Oct 2 2018, 8:42 PM

Change 464021 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.24] Hide copyvio, none afc filter options behind flag

https://gerrit.wikimedia.org/r/464021

Mentioned in SAL (#wikimedia-operations) [2018-10-02T23:38:39Z] <ladsgroup@deploy1001> Synchronized php-1.32.0-wmf.24/extensions/PageTriage/modules/ext.pageTriage.views.list/ext.pageTriage.listControlNav.underscore: SWAT: [[gerrit:464021|Hide copyvio, none afc filter options behind flag (T205918)]] (duration: 00m 56s)

Change 464397 had a related patch set uploaded (by Catrope; owner: Sbisson):
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.23] Hide copyvio, none afc filter options behind flag

https://gerrit.wikimedia.org/r/464397

Change 464397 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.23] Hide copyvio, none afc filter options behind flag

https://gerrit.wikimedia.org/r/464397

Mentioned in SAL (#wikimedia-operations) [2018-10-03T23:29:47Z] <catrope@deploy1001> Synchronized php-1.32.0-wmf.23/extensions/PageTriage/: Hide copyvio AFC filter option behind flag (T205918) (duration: 00m 57s)