Page MenuHomePhabricator

Wikitext is displaced in Diff on de.wikipedia when Benutzer:TMg/cleanDiff.js is used
Closed, ResolvedPublic

Description

When opening this Diff the last "+" segment shown displays as:

[[Wikipedia_Diskussion:Wartungsbausteinwettbewerb/Frühling_2018#Preisvergabe_Tabelle|Preise]] vom Frühjahrswettbewerb abrufen mögen, sofern noch nicht geschehen, da wird die ja nicht ewig bei der Wikimedia lagern lassen können. Grüße, -- [[Benutzer:Toni Müller|Toni]] ([[Benutzer Diskussion:Toni Müller|Diskussion]] | [[Wikipedia:Mentorenprogramm|Hilfe?]]) 18:54, 11. Okt. 2018 (CEST)* Vielleicht ist es an dieser Stelle eine ganz gute Gelegenheit nochmal darauf hinzuweisen, dass alle Teilnehmer ihre

with "* Vielleicht ist es an dieser Stelle eine ganz gute Gelegenheit nochmal darauf hinzuweisen, dass alle Teilnehmer ihre " highlited and displaced, so everything before the first link in this line is shown in the wrong place. It should be:

  • Vielleicht ist es an dieser Stelle eine ganz gute Gelegenheit nochmal darauf hinzuweisen, dass alle Teilnehmer ihre [[Wikipedia_Diskussion:Wartungsbausteinwettbewerb/Frühling_2018#Preisvergabe_Tabelle|Preise]] vom Frühjahrswettbewerb abrufen mögen, sofern noch nicht geschehen, da wird die ja nicht ewig bei der Wikimedia lagern lassen können. Grüße, -- [[Benutzer:Toni Müller|Toni]] ([[Benutzer Diskussion:Toni Müller|Diskussion]] | [[Wikipedia:Mentorenprogramm|Hilfe?]]) 18:54, 11. Okt. 2018 (CEST)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 14 2018, 6:37 PM

CCing TCB-Team, as they did major modifications to Diifs over the past two years (to resolve T139603: Show text changes when moving text chunks (#2)).

@MGChecker when I access the diff you linked, I get the desired result. Can you double check if the problem still exists for you?

@MGChecker when I access the diff you linked, I get the desired result. Can you double check if the problem still exists for you?

I just noticed this bug only appears with https://de.wikipedia.org/wiki/Benutzer:TMg/cleanDiff.js
. This explains this behavior and makes this task probably invalid.

thiemowmde added a subscriber: Schnark.

Oh, that's my script. I'm very much interested in fixing it, if there is a problem.

I still wasn't able to reproduce the problem with my script alone, but found it when running your entire common.js: It's a clash between my cleanDiff and @Schnark's linkUnlinked:

importScript( 'Benutzer:Schnark/js/linkUnlinked.js' );
importScript( 'Benutzer:TMg/cleanDiff.js' );

I will try to fix it when I have the time. Maybe Schnark can also have a look?

Aklapper renamed this task from Wikitext is displaced in Diff to Wikitext is displaced in Diff on de.wikipedia when Benutzer:TMg/cleanDiff.js is used.Oct 15 2018, 3:50 PM

Oh, that's my script. I'm very much interested in fixing it, if there is a problem.
I still wasn't able to reproduce the problem with my script alone, but found it when running your entire common.js: It's a clash between my cleanDiff and @Schnark's linkUnlinked:

importScript( 'Benutzer:Schnark/js/linkUnlinked.js' );
importScript( 'Benutzer:TMg/cleanDiff.js' );

I will try to fix it when I have the time. Maybe Schnark can also have a look?

Really interesting, didn't think so far (just did a quick check mobile after Lea pointed my mistake out to me). Thank you for your efforts!

thiemowmde closed this task as Resolved.Oct 16 2018, 6:45 AM
thiemowmde claimed this task.
thiemowmde triaged this task as Low priority.
Schnark removed a subscriber: Schnark.Oct 16 2018, 7:22 AM

I still wasn't able to reproduce the problem with my script alone, but found it when running your entire common.js: It's a clash between my cleanDiff and @Schnark's linkUnlinked:

I can reproduce with your script alone, I just opened the diff in a private tab, then executed mw.loader.load( '//de.wikipedia.org/w/index.php?title=Benutzer:TMg/cleanDiff.js&action=raw&ctype=text/javascript' ); in the console.

So I don't think this has anything to do with my script. Even if it is a clash, https://de.wikipedia.org/wiki/Benutzer:Schnark/js/linkUnlinked#Alternativen discourages use of both scripts at the same time anyway.

@Schnark, I think I was able to fix it just a few minutes ago. Can you please try again?

Works for me.