Page MenuHomePhabricator

Put separate buttons on wikitext toolbar for single and double brackets
Closed, DeclinedPublic

Description

See this thread:
*Wikipedia:Village pump (technical). Separate buttons for single and double bracket links in the editing toolbar. Find it in the archives when it is moved.

Until Nov 6, 2018 one could create an internal or external link with one click. That is when the 2006 wikitext editing toolbar was removed.

The 2010 and 2017 wikitext editing toolbars both have one button for creating links. Clicking it opens a popup menu.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 14 2018, 1:29 PM
Aklapper changed the task status from Open to Stalled.Nov 15 2018, 10:30 AM

Hi, please see https://www.mediawiki.org/wiki/How_to_report_a_bug and provide steps to reproduce the problem. We don't know which editor you use. Sticking to technical aspects when writing tasks would be very welcome. No idea which "popup box" this is about either and where to see that...

Put back 2 one-click link buttons on the wikitext editing toolbar. They were recently removed from the wikitext editing toolbar for some people.

Those 2 one-click (no intermediate popup box) link buttons are the first two icons on the left of the top line here:
*https://commons.wikimedia.org/wiki/MediaWiki:Edittools

Those icons are clearer than the icons used for the recently deleted buttons.

The popup box shows up when clicking the link button on this editing toolbar:
*https://commons.wikimedia.org/wiki/File:Wikitext_editing_toolbar.jpg

Aklapper closed this task as Declined.Nov 16 2018, 1:52 PM
Aklapper added a project: WikiEditor.

Put back 2 one-click link buttons on the wikitext editing toolbar.

There are no plans to expose random single elements as part of the top-level, hence declining.

Any community and/or user is free to adjust what's in the toolbar - see https://www.mediawiki.org/wiki/Extension:WikiEditor/Toolbar_customization
(Note that some limitations exist such as https://phabricator.wikimedia.org/T25624 or https://phabricator.wikimedia.org/T119324)

For example, the WikiEditor toolbar on Commons offers [[ under "Edittools":

Timeshifter added a comment.EditedNov 17 2018, 4:18 AM

For example, the WikiEditor toolbar on Commons offers [[ under "Edittools":

That does not work. As explained here:
*Wikipedia:Village pump (technical). Separate buttons for single and double bracket links in the editing toolbar.

After this was pointed out it was TheDJ who suggested I create this Phabricator task.

I am not trying to resurrect the old toolbars. I want 2 single-click link buttons (internal and external links) added to the end of the current toolbar used for wikitext editing.

TheDJ added a subscriber: TheDJ.EditedNov 17 2018, 11:26 AM

Just to be clear, I still don't understand Timeshifter's problem.

With direct keyboard input, auto interpretation of links in the dialog (also with keyboard accessibility) and the bottom inserter, I personally feel we have 3 good methods already.

But if he feels it's valid, there might be something to it that I'm missing.

Just to be clear, I still don't understand Timeshifter's problem.

I checked your user contributions on English Wikipedia and see that you are using the 2017 wikitext editor (a beta feature in preferences):
*https://www.mediawiki.org/wiki/2017_wikitext_editor

I enabled it today, and consider it to be a disaster. It has its good points, but speed is not one of them.

I explain in detail in the link below, and also suggest an easy solution: a customizable quick-launch 5-command toolbar section. Similar in principle to the customizable quick-launch taskbar in Windows.
*https://en.wikipedia.org/wiki/User_talk:Whatamidoing_(WMF)#When_were_single-click_link_buttons_removed?

I would put these 5 single-click commands (without popup intermediaries) in my quick-launch wikitext editor taskbar:
Bold
Italics
Internal link (double brackets)
External link (single brackets)
Signature

It gives me my wish for separate buttons for single and double brackets (the topic of this task). But it doesn't impose my choices on others who may prefer some initial coddling and handholding for creating links (the popup box).

Please read T209487#4753667 again. It links to an explanation how you can adjust the toolbar to suit your needs.

Please read T209487#4753667 again. It links to an explanation how you can adjust the toolbar to suit your needs.

That is a difficult, technical, and individual solution. I am not skilled in the areas required.

And if you look at the Community Wishlist Survey 2019 you see that some of the most popular requests have to do with the 2006 wikitext editor toolbar. See:
*https://meta.wikimedia.org/wiki/Community_Wishlist_Survey_2019/Editing/Put_mw.toolbar_back
*https://meta.wikimedia.org/wiki/Community_Wishlist_Survey_2019/Editing/Keep_the_lightweight_text_editor

My request in this Phabricator task deals with the core elements (in my opinion). And solves the problems for everybody, not just me. And without re-enabling the old toolbars.

The current version of the task contains a small error:

It was promised long ago that the wikitext editor would not ever be removed without user approval and consensus.

Not exactly. The promise is that wikitext editing would not be removed in the foreseeable future. Nobody has ever promised that every single one of the (dozens of) wikitext editors – or even any single favorite one of them – would continue to function forever. The promise is that there will be a way to edit wikitext directly. Exactly what tools are used to do that may (and probably will) change over time.

Timeshifter updated the task description. (Show Details)Nov 20 2018, 2:21 AM

For example, the WikiEditor toolbar on Commons offers [[ under "Edittools":

This would work with the 2017 wikitext editor on English Wikipedia! Because the toolbars would always stay fixed in place at the top and bottom of the screen. Always visible regardless of scrolling. See:
https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#2017_wikitext_editor._Keep_top_toolbar._Add_Commons_edit_tools_on_bottom

When I first replied to you I was using the 2010 wikitext editor and toolbar on English Wikipedia. In editing preferences: "Enable the editing toolbar. This is sometimes called the '2010 wikitext editor'."
*https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-editing
*https://commons.wikimedia.org/wiki/File:2010_wikitext_editing_toolbar.jpg

As I said, this idea did not work for me. The 2010 editing toolbar moves off the screen. There are 2 scroll bars if the text being edited is longer than the screen height. Moving/scrolling back and forth from the top to the bottom of the window is not a viable solution for frequently used markup buttons. It's not just a problem with the window size. The current menus at the bottom of the 2010 wikitext editing window do not stay open, or remember to start at "wiki markup". Stray mouse clicks while scrolling from top to bottom remove previous selections. It's just all-around unwieldy.