Page MenuHomePhabricator

Display map for property "OSM relation ID (P402)" statements
Closed, DeclinedPublic

Description

Currently the geocoordinate statements display a map. It would be nice if a map would be displayed for "OSM relation ID (P402)" statements as well. See past task: T184933

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 1 2019, 7:41 PM
Jc86035 added a subscriber: Jc86035.EditedJan 3 2019, 10:51 AM

It would also be useful to use the map to fetch the OSM items which are linked to the Wikidata item (edit: this is T173052). English Wikipedia's {{Infobox mapframe}} does this (example):

<mapframe zoom="13" frameless="1" align="center" height="200" latitude="-33.852232" longitude="151.210684" width="270">[
{"properties":{"stroke-width":3,"stroke":"#FF0000","title":"Sydney Harbour Bridge"},"type":"ExternalData","service":"geoshape","ids":"Q54495"},
{"properties":{"stroke-width":5,"stroke":"#FF0000","title":"Sydney Harbour Bridge"},"type":"ExternalData","service":"geoline","ids":"Q54495"},
{"type":"Feature","geometry":{"coordinates":[151.210684,-33.852232],"type":"Point"},"properties":{"title":"Sydney Harbour Bridge","marker-color":"#5E74F3"}}
]</mapframe>
Pikne added a subscriber: Pikne.Jan 3 2019, 11:58 AM

Using this property is sort of discouraged (T145284). Rather than building upon it, T173052 seems like a way forward.

Jc86035 added a comment.EditedJan 3 2019, 12:43 PM

@Pikne, the property was kept after the deletion discussion mentioned in T145284. However, there are 17 times more Wikidata IDs in OSM than there are OSM relation IDs in Wikidata, so I agree T173052 would be much more useful.

MSantos moved this task from All map-related tasks to Tracking on the Maps board.Jan 8 2019, 4:07 PM
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptApr 16 2019, 5:58 AM
Aklapper reopened this task as Open.Apr 16 2019, 7:39 AM
Aklapper updated the task description. (Show Details)

@Micru: This task is not invalid ("when the problem is not a bug, or when it is a change that is outside the power of the component's developers") until there are specific reasons provided.

Lydia_Pintscher closed this task as Declined.Apr 17 2019, 6:45 AM
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

If people are interested in this I think it should start out as a gadget. I currently don't think it'll go into Wikibase itself unless there is huge demand.