Page MenuHomePhabricator

Warning: Missing ipb_reason_text and ipb_reason_data fields in row with
Closed, ResolvedPublic

Description

Setup

  • MediaWiki 1.32.0-rc.1 (92ea1ec) 22:07, 27 December 2018
  • PHP 7.0.33-0+deb9u1 (apache2handler)
  • MariaDB 10.1.37-MariaDB-0+deb9u1
  • UserMerge 1.10.1 (891619a) 22:22, 1 January 2019

Issue
Then performing a user merge I get the following warning:

Warning: Missing ipb_reason_text and ipb_reason_data fields in row with MIGRATION_OLD [Called from CommentStore::getCommentInternal in /../w/includes/CommentStore.php at line 285] in /../w/includes/debug/MWDebug.php on line 309

Since I am not sure what is causing this issue I added all possible applicable tags. Please remove as see fit.

Event Timeline

Kghbln created this task.Jan 2 2019, 6:35 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 2 2019, 6:35 PM
Legoktm moved this task from Backlog to Extensions on the MW-1.32-release board.Jan 3 2019, 6:32 PM

Which component is the error coming from? A special page? (which one), an API request (which one), etc.

Which component is the error coming from? A special page? (which one), an API request (which one), etc.

Caused by using "Special:UserMerge". I cannot tell if this one is calling the API at one stage or not to do its job.

Change 524530 had a related patch set uploaded (by Anomie; owner: Anomie):
[mediawiki/extensions/UserMerge@master] Replace '*' query with DatabaseBlock::getQueryInfo()

https://gerrit.wikimedia.org/r/524530

Anomie claimed this task.Jul 23 2019, 4:14 PM

Change 524530 merged by jenkins-bot:
[mediawiki/extensions/UserMerge@master] Replace '*' query with DatabaseBlock::getQueryInfo()

https://gerrit.wikimedia.org/r/524530

Anomie closed this task as Resolved.Jul 24 2019, 1:45 PM

This is now fixed in the master branch of MediaWiki-extensions-UserMerge. If you're using an older release version, you should be able to backport the patch.

Kghbln added a comment.EditedJul 24 2019, 1:55 PM

This is now fixed in the master branch of

You are cool! Thanks for the effort! Much appreciated!!! :)

If you're using an older release version, you should be able to backport the patch.

Since it only started with MW 1.33 a backport to REL_1_33 should do the trick. I will cherry-pick right now!

Change 525286 had a related patch set uploaded (by Kghbln; owner: Anomie):
[mediawiki/extensions/UserMerge@REL1_33] Replace '*' query with DatabaseBlock::getQueryInfo()

https://gerrit.wikimedia.org/r/525286

Change 525286 merged by Jforrester:
[mediawiki/extensions/UserMerge@REL1_33] Replace '*' query with DatabaseBlock::getQueryInfo()

https://gerrit.wikimedia.org/r/525286

Cool. Thanks a ton. You rock!