Page MenuHomePhabricator

Make the CAPTCHA display on the initial edit page when possible
Closed, ResolvedPublic

Description

As it is, the CAPTCHA doesn't appear until you try saving your edit. If the CAPTCHA will definitely be displayed for an edit (because $wgCaptchaTriggers['edit'] or $wgCaptchaTriggersOnNamespace[NS_FOO]['edit'] is set), we should show it on the edit page before the user presses "Save page."


Version: unspecified
Severity: enhancement
URL: http://lists.wikimedia.org/pipermail/mediawiki-l/2009-July/031468.html
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=9406
https://bugzilla.wikimedia.org/show_bug.cgi?id=73070

Details

Reference
bz19648

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:39 PM
bzimport set Reference to bz19648.
  • Bug 65913 has been marked as a duplicate of this bug. ***

Copying stuff from bug 65913...

Nemo said in bug 65913 comment 2:

Thanks for working on this. It's indeed an issue that the user

  1. has to double the minimum "save" clicks required,
  2. may not notice that the edit wasn't saved and neglect to confirm it with

the captcha.
I assume we're not talking of the cases where an "addurl" captcha could be
triggered though, because we can't know beforehand whether the user will add
an URL; updated summary.

Change 136323 had a related patch set uploaded by Legoktm:
Show Captcha after click on edit over buttons on EditPage

https://gerrit.wikimedia.org/r/136323

  • Bug 43122 has been marked as a duplicate of this bug. ***
Florian closed this task as Resolved.Dec 30 2014, 8:01 PM

Change merged.