Page MenuHomePhabricator

Starting a new page from scratch does not lead directly to Visual Editor, causing the result not to be tagged
Open, MediumPublic

Description

When accessing the options to contribute for an article that does not exists locally (example), there is an option to start from scratch. This is expected to lead to Visual editor, but currently it leads to the missing page (example). In such page, there are options to create the newpage, but these options do not propagate the campaign parameter, which result in the corresponding tag not to be added to the result.

This was tested on Desktop, by changing the page name to make sure it is created under my user namespace.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 8 2019, 12:46 PM
Pginer-WMF triaged this task as High priority.Mar 8 2019, 12:47 PM
Pginer-WMF added a subscriber: santhosh.

Interestingly, I did not get those actions:
With the URL:
https://id.wikipedia.org/w/index.php?title=User:Santhosh.thottingal/Bearded_dragon&veaction=edit&campaign=external-machine-translation
I get

And published a page https://id.wikipedia.org/w/index.php?title=Pengguna:Santhosh.thottingal/Bearded_dragon&action=history

This was tested on Desktop, by changing the page name to make sure it is created under my user namespace.

Did you delete the veaction=edit accidentally while editing the URL?

Pginer-WMF closed this task as Invalid.Mar 11 2019, 5:55 PM

I tried again and this seems to work fine, going directly to editing mode and adding an edit tag:


I'm closing the ticket since I could not reproduce the issue again (I didn't manipulated the URL directly). If the issues reappears I'll reopen.

Pginer-WMF reopened this task as Open.Mar 14 2019, 1:55 PM

@santhosh, I experienced the issue again. It seems to happen in an edge case so I don't expect to affect many contributions.

Here are the steps to reproduce:

  1. On desktop, access the contribution options page for an article that does not exist in Indonesian (example)
  2. Select the option to start by translating. Content translation will be open in a new tab.
  3. Close the Content translation tab to go back to the previous view.
  4. Select this time to start by scratch. Then a new tab is open to the new page but not on edit mode (example)
Pginer-WMF lowered the priority of this task from High to Medium.Mar 14 2019, 1:56 PM
santhosh claimed this task.Mar 18 2019, 6:34 AM

Change 497230 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ExternalGuidance@master] Remove unnecessary change of the edit params

https://gerrit.wikimedia.org/r/497230

santhosh moved this task from Backlog to In Review on the ExternalGuidance board.Mar 18 2019, 6:34 AM

Change 497230 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ExternalGuidance@master] Remove unnecessary change of the edit params

https://gerrit.wikimedia.org/r/497230

Change 497230 merged by Santhosh:
[mediawiki/extensions/ExternalGuidance@master] Remove unnecessary change of the edit params

https://gerrit.wikimedia.org/r/497230

santhosh moved this task from In Review to Done on the ExternalGuidance board.Mar 20 2019, 4:20 AM