Page MenuHomePhabricator

[Regression] Opening a section with section edit link on mobile VE doesn't open the article at that position anymore
Closed, ResolvedPublic

Description

Steps to replicate:

  1. On mobile VE, open any section using section edit link.

The article opens but it scrolls up to the top, instead of opening it at the position of that section heading.

Event Timeline

Ryasmeen created this task.Mar 15 2019, 7:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 15 2019, 7:57 PM

I can't reproduce this. Tested on https://en.m.wikipedia.org/wiki/The_Fighting_Temeraire:

@matmarex: Here is the screen capture showing the scroll up issue from my sandbox on en.wiki:

(only affects iOS Safari)

I can reproduce now. I am pretty sure I tested with iOS Safari before as well (unfortunately I did not record it) and couldn't reproduce. Section editing has to be disabled to see the problem, maybe I had it enabled.

I have a patch for this which I will upload when Gerrit is back up. The fix is to delete ve.init.mw.MobileArticleTarget.prototype.scrollToHeading :)

Change 497482 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] MobileArticleTarget: Remove broken iOS override for #scrollToHeading

https://gerrit.wikimedia.org/r/497482

Change 497482 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] MobileArticleTarget: Remove broken iOS override for #scrollToHeading

https://gerrit.wikimedia.org/r/497482

@matmarex: This needs to be tested on a wiki with section editing disabled, so I will wait until it's on en.wiki?

@matmarex: Alrighty! So I checked this today on en.wiki, looks okay to me. I just have one question:

Towards the end of a document if the sections are too short as in there is just not enough content to fill in the entire screen, it's opening the article slightly above the section, which makes sense to me, but just wanted to confirm with you that this is indeed the expected behavior in this case :)

Video capture for better understanding: (I clicked the section edit link next to the last section "new section edit"

@Ryasmeen Argh, that seems to be a general problem with the loading overlay (not specific to iOS Safari, like this bug). I copied your comment to that task: T210630#5068517. It's a valid issue but I'm not sure if it's worth working on (see my comment there).

I don't think it's related to this task; if that's the only issue, then I think we can resolve this.

@Ryasmeen Argh, that seems to be a general problem with the loading overlay (not specific to iOS Safari, like this bug). I copied your comment to that task: T210630#5068517. It's a valid issue but I'm not sure if it's worth working on (see my comment there).

I don't think it's related to this task; if that's the only issue, then I think we can resolve this.

Sounds good!

Ryasmeen edited projects, added Verified; removed Patch-For-Review.Mar 29 2019, 8:42 PM
Ryasmeen moved this task from QA to Product owner review on the VisualEditor (Current work) board.
ppelberg closed this task as Resolved.Apr 23 2019, 12:34 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptApr 23 2019, 12:34 AM