Page MenuHomePhabricator

Not possible to edit forms of Wikidata lexemes
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

Go to: https://www.wikidata.org/wiki/Lexeme:L12912

Press edit at L12912-F2

Actual Results:

No edit box is shown for the form and its grammatical representation.

Expected Results:

Edit box should be shown.

Event Timeline

Fnielsen created this task.Mar 31 2019, 4:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 31 2019, 4:14 PM

The console says “TypeError: text.trim is not a function” and then after a second click “TypeError: this._grammaticalFeatureListWidget is null”, so I assume this is the same bug as T219134: `text.trim is not a function` in node selenium tests blocking Wikibase CI; blocking test/merge in WB/WBL/WBMI/etc., and we should backport the fix ASAP.

Change 500237 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Jakob):
[mediawiki/extensions/WikibaseLexeme@wmf/1.33.0-wmf.23] Fix GrammaticalFeatureListWidget

https://gerrit.wikimedia.org/r/500237

Backport scheduled for tomorrow’s EU SWAT.

Change 500237 merged by jenkins-bot:
[mediawiki/extensions/WikibaseLexeme@wmf/1.33.0-wmf.23] Fix GrammaticalFeatureListWidget

https://gerrit.wikimedia.org/r/500237

Mentioned in SAL (#wikimedia-operations) [2019-04-01T11:57:54Z] <lucaswerkmeister-wmde@deploy1001> Synchronized php-1.33.0-wmf.23/extensions/WikibaseLexeme: SWAT: [[gerrit:500237|Fix GrammaticalFeatureListWidget (T219134, T219734)]] (duration: 01m 00s)

The fix works for me. Thanks!

currentDay gadget for P813 now in troubles. I wonder if the fix/changes related to this issue.

Mbch331 added a subscriber: Mbch331.Apr 1 2019, 5:09 PM

It works for me:


I entered P813 in the first field and the date got filled in automatically.

Yes. This may have been a temporary issue.

Fnielsen closed this task as Resolved.Apr 4 2019, 2:49 PM