Page MenuHomePhabricator

Special:Statistics shows -1 active users
Closed, ResolvedPublic

Description

In the ksh Wikipedia, there are currently -1 active users
shown in Special:Statistics.
The reason why is, likely, that the cached counts in the database
have been reset. The reason for the reset is, likely, that the
"god article" count fell below zero.

This should not result in -1 active users.

This bug is related to bug 19919.


Version: 1.18.x
Severity: minor
URL: http://ksh.wikipedia.org/wiki/Special:Statistics
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=54888

Details

Reference
bz20017

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 10:47 PM
bzimport set Reference to bz20017.
bzimport added a subscriber: Unknown Object (MLST).
Nakon added a comment.Aug 5 2009, 3:38 AM

The page now shows 44 active users.

You've been too late. Meanwhile it does show 44 active users, since
the usual update cycle of the active users count had been reached.
The page showed -1 users, as our bot noted in your daily statics page
http://ksh.wikipedia.org/wiki/Wikipedia:Statistike#Ripoarisch_Wikkipedija_.C2.A0_Auju.C3.9F.C3.9F_2009
automatically, too, the figures in which are simply copied from
http://ksh.wikipedia.org/wiki/Spezial:Statistik?action=raw
once at night. There is a slight chance that the count could be reset
once more (unlikely, though) if it does, and I catch it, I make a
screenshot.

Special:Statistics page of kshwiki 2009-Aug-07, ~10:20 (CEDT), cropped.

Here is the promised screen shot. If you want to see -1 active useres life in the wiki, be quick! :-)

Attached:

(In reply to comment #3)

Created an attachment (id=6432) [details]
Special:Statistics page of kshwiki 2009-Aug-07, ~10:20 (CEDT), cropped.
Here is the promised screen shot. If you want to see -1 active useres life in
the wiki, be quick! :-)

I encountered this bug on fresh install of Mediawiki 1.15.1 (PHP 5.2 and MySQL 4.1)

I've noticed this on other wikis running 1.15.1 as well:
(http://www.alliancewiki.info/index.php?title=Special:Statistics)

I think it's not really an "enhancement". It seems like a legit bug to me, so I'm changing the importance, if you don't mind.

  • Bug 28473 has been marked as a duplicate of this bug. ***
He7d3r added a comment.Jun 8 2011, 2:34 AM

It just happened again on another fresh install of MW from trunk (1.19-svn?). I noticed it after I ran
php importDump.php ~/Downloads/ptwikibooks-20110531-pages-meta-current.xml
(although I didn't look at the page before this). The wiki has only one user, and [[Special:Statistics]] displayed


Registered users | 1 |

Active users (list of members) | |
(Users who have performed an action in the | -1 |

last 30 days) | |

kipmaster wrote:

I have a similar bug with OmegaWiki (see Statistics http://www.omegawiki.org/Special:Statistics )

However, when I do a "php maintenance/initStats.php --active " (with or without --update) , it shows 17, which is probably right.
But a "select * from site_stats" shows -1 so the number was not correctly submitted to the database (or was reinitialized afterwards?)

MediaWiki version 1.19alpha (r91414)

kipmaster wrote:

Correction to my previous comment:
it does work with --active --update
However, if I run again the script after that, just with --active , it puts again -1 in the database.

sumanah wrote:

So, the temporary workaround is for a site administrator to run

php maintenance/initStats.php --active --update

(the stats maintenance script) on the command line? And I'm not quite clear on how often they might have to do that until there's a real fix.

sumanah wrote:

Happening to at least one 1.18.1 wiki ( http://theopenglobe.org/wiki/Special:Statistics ).

With gerrit 65133 the stored active_users field in the database will be checked and a negative value will trigger a recalculate of the count. That means, this situation will now occurs less often, but I am not sure, if this is fixed in all code path.

(In reply to Umherirrender from comment #13)

With Gerrit change #65133 the stored active_users field in the database will
be checked and a negative value will trigger a recalculate of the count.
That means, this situation will now occurs less often, but I am not sure, if
this is fixed in all code path.

Seen on pl.wp today

(In reply to Umherirrender from comment #13)

With Gerrit change #65133 the stored active_users field in the database will
be checked and a negative value will trigger a recalculate of the count.

Related: https://gerrit.wikimedia.org/r/#/c/114994/

Can we consider this resolved now?

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2015, 9:20 PM

Cannot reproduce on any of the links on this page, I would say close as resolved.

Krenair closed this task as Resolved.Nov 26 2015, 5:01 PM
Krenair claimed this task.
Meno25 removed a subscriber: Meno25.Nov 29 2015, 7:27 PM