Page MenuHomePhabricator

[Bug] Unexpected result set returned by Elasticsearch
Closed, ResolvedPublic

Description

About 9 errors were logged for "Unexpected result set returned by Elasticsearch." Is this expected?

message
[XKihgQpAAK4AAC9O9OMAAADK] /w/api.php?action=query&prop=pageimages%7Cextracts%7Ccoordinates&pilimit=max&pithumbsize=320&piprop=thumbnail&generator=geosearch&format=json&explaintext=true&exlimit=max&exintro=true&ggsradius=10000&ggscoord=59.245984%7C10.3962818&ggslimit=3   MWException from line 2218 of /srv/mediawiki/php-1.33.0-wmf.23/includes/api/ApiBase.php: Internal error in GeoData\ApiQueryGeoSearchElastic::run: Unexpected result set returned by Elasticsearch
exception.trace
#0 /srv/mediawiki/php-1.33.0-wmf.23/extensions/GeoData/includes/api/ApiQueryGeoSearchElastic.php(112): ApiBase::dieDebug(string, string)
#1 /srv/mediawiki/php-1.33.0-wmf.23/extensions/GeoData/includes/api/ApiQueryGeoSearch.php(55): GeoData\ApiQueryGeoSearchElastic->run(ApiPageSet)
#2 /srv/mediawiki/php-1.33.0-wmf.23/includes/api/ApiPageSet.php(176): GeoData\ApiQueryGeoSearch->executeGenerator(ApiPageSet)
#3 /srv/mediawiki/php-1.33.0-wmf.23/includes/api/ApiPageSet.php(140): ApiPageSet->executeInternal(boolean)
#4 /srv/mediawiki/php-1.33.0-wmf.23/includes/api/ApiQuery.php(234): ApiPageSet->execute()
#5 /srv/mediawiki/php-1.33.0-wmf.23/includes/api/ApiMain.php(1595): ApiQuery->execute()
#6 /srv/mediawiki/php-1.33.0-wmf.23/includes/api/ApiMain.php(531): ApiMain->executeAction()
#7 /srv/mediawiki/php-1.33.0-wmf.23/includes/api/ApiMain.php(502): ApiMain->executeActionWithErrorHandling()
#8 /srv/mediawiki/php-1.33.0-wmf.23/api.php(87): ApiMain->execute()
#9 /srv/mediawiki/w/api.php(3): include(string)
#10 {main}

Details

Related Gerrit Patches:
mediawiki/extensions/GeoData : masterTransform non 2xx search response into exception
mediawiki/extensions/GeoData : masterHandle elasticsearch timeouts
mediawiki/extensions/GeoData : masterLog unexpected response from elasticsearch

Event Timeline

Restricted Application added a project: Discovery-Search. · View Herald TranscriptApr 10 2019, 5:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Not expected, although hard to say what the error is. GeoData error handling needs to be updated log whatever the response it didn't like was

EBernhardson triaged this task as Normal priority.Apr 11 2019, 5:06 PM
EBernhardson moved this task from needs triage to Geodata on the Discovery-Search board.

Change 503118 had a related patch set uploaded (by EBernhardson; owner: EBernhardson):
[mediawiki/extensions/GeoData@master] Log unexpected response from elasticsearch

https://gerrit.wikimedia.org/r/503118

Change 503118 merged by jenkins-bot:
[mediawiki/extensions/GeoData@master] Log unexpected response from elasticsearch

https://gerrit.wikimedia.org/r/503118

Change 514161 had a related patch set uploaded (by EBernhardson; owner: EBernhardson):
[mediawiki/extensions/GeoData@master] Handle elasticsearch timeouts

https://gerrit.wikimedia.org/r/514161

Change 514162 had a related patch set uploaded (by EBernhardson; owner: EBernhardson):
[mediawiki/extensions/GeoData@master] Transform non 2xx search response into exception

https://gerrit.wikimedia.org/r/514162

Change 514161 merged by jenkins-bot:
[mediawiki/extensions/GeoData@master] Handle elasticsearch timeouts

https://gerrit.wikimedia.org/r/514161

Change 514162 merged by jenkins-bot:
[mediawiki/extensions/GeoData@master] Transform non 2xx search response into exception

https://gerrit.wikimedia.org/r/514162

We left this in waiting/blocked because we weren't sure there the 5xx's were coming from. It looks probable this has the same root cause as T228063, so closing this for now. Can re-open if the problem persists.

debt closed this task as Resolved.Jul 24 2019, 5:33 PM