Page MenuHomePhabricator

PHP Notice: Undfined index: page_latest in //includes/ChangesList.php on line 476
Closed, ResolvedPublic

Description

Happens with old and enhanced changes list with example url: title=Special:RecentChangesLinked/Portal:Ar/translators

Backtrace:

  • ChangesList.php line 476 calls wfBacktrace()
  • ChangesList.php line 573 calls ChangesList::insertRollback()
  • SpecialRecentchanges.php line 397 calls OldChangesList::recentChangesLine()
  • SpecialRecentchanges.php line 122 calls SpecialRecentChanges::webOutput()
  • SpecialPage.php line 559 calls SpecialRecentChanges::execute()
  • Wiki.php line 236 calls SpecialPage::executePath()
  • Wiki.php line 63 calls MediaWiki::initializeSpecialCases()
  • index.php line 116 calls MediaWiki::performRequestForTitle()

Notice: Undefined index: page_latest in /var/www/sandwiki/includes/ChangesList.php on line 477


Version: 1.16.x
Severity: normal

Details

Reference
bz20131

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 10:54 PM
bzimport set Reference to bz20131.
bzimport added a subscriber: Unknown Object (MLST).
IAlex added a comment.Aug 8 2009, 8:47 PM

fixed in r54641.

  • Bug 18251 has been marked as a duplicate of this bug. ***
Prod added a comment.Sep 6 2009, 5:42 PM

This also affect the 1.15 branch as I was seeing this error in my 1.15.1 install. I implemented the fix mentioned and it seems to have fixed the problem.

(In reply to comment #3)

This also affect the 1.15 branch as I was seeing this error in my 1.15.1
install. I implemented the fix mentioned and it seems to have fixed the
problem.

This issue has been fixed on trunk, and is not serious enough to backport to 1.15 (it's just a PHP warning). Reclosing.

tim wrote:

I am on 1.15.1. I grabbed the fixed file (SpecialRecentchangeslinked.php), but now I have a different error:

PHP Fatal error: Call to undefined method DatabaseMysql::unionQueries() in C:\inetpub\wwwroot\MediaWiki\includes\specials\SpecialRecentchangeslinked.php on line 163

Is there another file to go with the patch?

MaxSem added a comment.Mar 5 2010, 4:36 PM

Of course, if you take one single file from the future version, it may require things introduced to other files since 1.15. But if you copy Database.php and DatabaseMysql.php to fix this warning, they may require newer GlobalFunctions and DefaultSettings, and so on, until you've dragged over whole trunk. Please just wait for 1.16 release.

tim wrote:

OK, sorry. I saw "patch" and assumed that was the entire fix. In my dev environment, we consider a "patch" to consist of all fixes for an issue. It seems there's a different definition here.

(In reply to comment #7)

OK, sorry. I saw "patch" and assumed that was the entire fix. In my dev
environment, we consider a "patch" to consist of all fixes for an issue. It
seems there's a different definition here.

We use the same definition, but the difference between SpecialRecentchanges.php in 1.15.1 and the same file in trunk consists of much more than just this one patch, and some of these differences rely on changes in other files.