Page MenuHomePhabricator

beta-scap-eqiad failing – "Call to mwscript eval.php returned: None"
Closed, ResolvedPublic0 Estimated Story Points

Description

https://integration.wikimedia.org/ci/view/Beta/job/beta-scap-eqiad/251269/console

15:04:20 22:04:20 Scap failed!: Call to mwscript eval.php returned: None
15:04:20 22:04:20 Unhandled error:
15:04:20 Traceback (most recent call last):
15:04:20   File "/usr/lib/python2.7/dist-packages/scap/cli.py", line 342, in run
15:04:20     exit_status = app.main(app.extra_arguments)
15:04:20   File "/usr/lib/python2.7/dist-packages/scap/main.py", line 604, in main
15:04:20     return super(Scap, self).main(*extra_args)
15:04:20   File "/usr/lib/python2.7/dist-packages/scap/main.py", line 80, in main
15:04:20     self._check_fatals()
15:04:20   File "/usr/lib/python2.7/dist-packages/scap/main.py", line 217, in _check_fatals
15:04:20     raise RuntimeError(errmsg.format('returned', exit_code))
15:04:20 RuntimeError: Scap failed!: Call to mwscript eval.php returned: None
15:04:21 22:04:20 scap failed: RuntimeError Scap failed!: Call to mwscript eval.php returned: None (duration: 00m 00s)
15:04:21 Build step 'Execute shell' marked build as failure

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 29 2019, 10:14 PM
Jdforrester-WMF added a subscriber: Reedy.

beta-update-databases-eqiad is also failing, with a specific error:

/usr/local/bin/mwscript update.php --wiki=aawiki --quick

Notice: Undefined variable: wgCirrusSearchWeights in /srv/mediawiki-staging/wmf-config/CirrusSearch-common.php on line 98

Possibly the same fault. Likely caused by 0503000e29dcc662e1535837218c910926227acd?

Restricted Application added a project: Discovery-Search. · View Herald TranscriptMay 29 2019, 10:28 PM

Change 513232 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[operations/mediawiki-config@master] CirrusSearch-common: Define wgCirrusSearchWeights and wgCirrusSearchNamespaceWeights locally

https://gerrit.wikimedia.org/r/513232

Change 513232 merged by jenkins-bot:
[operations/mediawiki-config@master] CirrusSearch-common: Define wgCirrusSearchWeights and wgCirrusSearchNamespaceWeights locally

https://gerrit.wikimedia.org/r/513232

Mentioned in SAL (#wikimedia-operations) [2019-05-29T22:46:35Z] <jforrester@deploy1001> Synchronized wmf-config/CirrusSearch-common.php: Hot-deploy T224634 to fix CirrusSearch for extension registration (duration: 00m 57s)

Jdforrester-WMF closed this task as Resolved.May 29 2019, 10:53 PM
Jdforrester-WMF claimed this task.