Page MenuHomePhabricator

English Wikipedia shows the "cannot be published" warning, even though I would be able to publish
Closed, ResolvedPublic

Description

I started a new translation in the English Wikipedia and I saw the warning: "Your translation cannot be published because publishing is only allowed to more experienced editors on this wiki."

This happened even though I have over 17,000 edits and belong to the Administrators group.

The likely reason is that I don't explicitly belong to the Extended confirmed group. Users are auto-promoted to this group at 500 edits, and I reached 500 edits long before it was created.

Event Timeline

Amire80 created this task.Jun 10 2019, 7:31 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 10 2019, 7:31 AM

Are you a sysop on enwiki? According to this rule, account needs not be in "sysop" or "bot" groups, to be added to "extendedconfirmed".

Either all sysops on enwiki will see this error or all users who reached 500 edits before this rule was created, which is even worse.

Yes, I am a sysop.

Can we maybe add a rule in CX configuration that sysops won't see the warning?

Yes, I am a sysop.
Can we maybe add a rule in CX configuration that sysops won't see the warning?

Currently, configuration works so that user needs to be member of all groups listed. If we add "sysop", basically no one would be able to publish on enwiki, since it will require user to be part of both "extendedconfirmed" and "sysop" groups, which I suspect no one is.

Since only enwiki currently really uses this config, we could make that user needs to be part of any group listed and then add "sysop" to the list.

Since only enwiki currently really uses this config, we could make that user needs to be part of any group listed and then add "sysop" to the list.

Makes sense.

Change 518257 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Require only one user group to allow publishing to main namespace

https://gerrit.wikimedia.org/r/518257

Change 518260 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[operations/mediawiki-config@master] Don't show cannot publish error to 'sysop' users

https://gerrit.wikimedia.org/r/518260

Change 518257 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Require only one user group to allow publishing to main namespace

https://gerrit.wikimedia.org/r/518257

Change 519780 had a related patch set uploaded (by KartikMistry; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@wmf/1.34.0-wmf.11] Require only one user group to allow publishing to main namespace

https://gerrit.wikimedia.org/r/519780

Change 519780 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@wmf/1.34.0-wmf.11] Require only one user group to allow publishing to main namespace

https://gerrit.wikimedia.org/r/519780

Mentioned in SAL (#wikimedia-operations) [2019-07-01T18:46:12Z] <urbanecm@deploy1001> Synchronized php-1.34.0-wmf.11/extensions/CentralAuth: SWAT: [[:gerrit:519780|Require only one user group to allow publishing to main namespace]] (T225398) (duration: 00m 51s)

Change 518260 merged by jenkins-bot:
[operations/mediawiki-config@master] Don't show cannot publish error to 'sysop' users

https://gerrit.wikimedia.org/r/518260

Mentioned in SAL (#wikimedia-operations) [2019-07-01T18:49:30Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SSWAT: [[:gerrit:518260|Dont show cannot publish error to sysop users]] (T225398) (duration: 00m 49s)

Mentioned in SAL (#wikimedia-operations) [2019-07-01T18:53:10Z] <urbanecm@deploy1001> Synchronized php-1.34.0-wmf.11/extensions/ContentTranslation: SWAT: [[:gerrit:519780|Require only one user group to allow publishing to main namespace]] (T225398) (duration: 00m 49s)

The fixes should be deployed. Can a enwiki sysop verify this, please?

Looks good to me as a sysop.

To be on the safe side, it should also be verified by a non-sysop extended confirmed user and by a non-extended-confirmed user.

I see the error as non-extendedconfirmed user.

Amire80 closed this task as Resolved.Jul 8 2019, 12:08 PM