Page MenuHomePhabricator

Update nodejs10 image to use the latest version of the package
Closed, ResolvedPublic

Description

Apparently our current nodejs10 image doesn't have the zlib "fix" needed for various node software to work on node 10.

We should rebuild it with the latest version of our packages.

Event Timeline

Joe claimed this task.Jun 24 2019, 6:02 AM
Joe triaged this task as High priority.
Joe created this task.
Joe moved this task from Backlog to Doing on the serviceops board.

While I'm at it, I'll upgrade all production images with new base images too.

Change 518468 had a related patch set uploaded (by Giuseppe Lavagetto; owner: Giuseppe Lavagetto):
[operations/docker-images/production-images@master] Refresh nodejs10-slim image

https://gerrit.wikimedia.org/r/518468

Change 518468 merged by Giuseppe Lavagetto:
[operations/docker-images/production-images@master] Refresh nodejs10-slim image

https://gerrit.wikimedia.org/r/518468

Mentioned in SAL (#wikimedia-operations) [2019-06-24T06:31:03Z] <_joe_> publishing docker-registry.wikimedia.org/nodejs10-slim:0.0.2, T226346

Joe closed this task as Resolved.Jun 24 2019, 6:31 AM